Mission in PX4 fixed wing vehicle

Hello everyone,
While I was trying to assign a mission and tried to start it in real life test on fixed-wing, I encountered some problems. Firstly, although I assigned takeoff waypoint, it did not takeoff. Arming was okay and there was thrust bu it was not enough. Also, I got some errors about landing pattern although I assigned one. Later I checked logs and saw an error message like this: error: mission upload failed. This was only error, everything other than that was okay. I wonder what is wrong. I really appreciate if someone can help me.

Please upload a log.

Here is the log file. This.
Thank you for your effort.

Landing pattern error was about the default glide slope. It needed to be lower. You don’t have gps or enough SATs. No position showed up in the log. You tried to arm in a non manual mode which if is the intent can only be mission. You had quite a bit of speed so if it wasn’t enough I’d also look at your hardware setup. That’s just a quick pass for you.

Thank you for your answer. As I remember, the number of SATs were higher than 12, which means GPS works well as I know. To start mission I confirmed it on QGC screen then the vehicle was armed, however it did not takeoff. Is this the correct way to start mission, can you enlighten me about mission initialization and steps in PX4? Hardware setup:

  • Firmware: Standard plane
  • Pixhawk Cube Orange
  • 2 aileron, 1 elevator, 1 rudder controlled through actuator control in aux’s and main’s
  • Motor is at the nose of the plane, T-motor 1250 kv
  • PID auto-start parameter is enabled so it is done automatically as explained in PX4 page

In mission I dis not change parameters related to speed, I left them as default. Could you give me some information about mission setup and possible reasons that caused problems?