MAV_FWDEXTSP not 1 help

So I was an idiot and accidentally changed the wrong parameter in my MANTIS G and set MAV_FWDEXTSP to 2 when I shouldn’t have and now I can’t connect to the drone. Is there a way to access this drone through a wired connection and change the parameter in QGC so I can connect this drone again. I have tried factory resetting through the Yuneec app but the app says that the drone is being controlled by another device and I cant change it.

So you can’t connect over QGC in Wifi anymore? Have you tried connecting using USB?

I have tried but I can’t seem to get QGC to connect to the Mantis over wired connection. Usually it just auto detects and connects to the drone once I have connected to its WiFi network. When I plug the drone in I can only see a .cm0013 file and a couple of empty folders. Is there a way to connect the Mantis to QGC with a wired connection?

When looking at the MAVLink Inspector I am getting live updates from the drone so It seems as if the drone is “connected” or rather the link is being monitered. Is there a way to use the MAVLink console to change a parameter?

Yes, if you have access to the MAVLink console you an set the param using:


I tried typing these commands in to the MAVLink console however I don’t think the console is connected to the drone since there wasn’t a wired connection and the Mantis doesn’t allow wired access to the MAVLink Console. Is there a way to connect the MAVLink console over WiFi?

MAVlink would have to work in the first place. :neutral_face:

I would try to reflash the firmware if you can from an update from the Yuneec page, and otherwise try their support.