Can't change parameters using QGC, after changing MAV_SYS_ID from 1 to 2

I’m using PX4 FW Version 1.13.3 on a pix32v6
Using QGC, I changed MAV_SYS_ID from 1 to 2
After doing that, the QGC Vehicle Setup screen doesn’t show the controls for changing parameters. It only shows the Summary & Firmware buttons).
“Q > Analyze Tools > MAVLink Console” also doesn’t work.
“Q > Analyze Tools > MAVLink Inspector” does work, and show MAVLink messages from the autopilot. For example, it indicates Component = 2 (not an autopilot?)
I tried the methods suggested at the following, but none worked:

I tried using Mission Planner to list all parameters (“list all parameters” or “full parameter tree”), but those functions failed.
What are alternate methods to change parameters (or reset all of them to defaults)?

Hi, I am having the exact same issue over here.

I found that the problem was caused by setting MAV_COMP_ID = 2, and not by setting MAV_SYS_ID = 2. Setting MAV_SYS_ID = 2 is fine, but MAV_COMP_ID must be 1 to indicate that it’s an autopilot.

I was able to recover by doing the following (hack):

  1. Add (the last 2 lines of) the following in “src/modules/mavlink/mavlink_main.cpp”:

    int comp_id = _param_mav_comp_id.get();

    if (comp_id > 0 && comp_id < 255) {
    mavlink_system.compid = comp_id;

    // @@TODO: Remove after test: Force (MAV_COMP_ID = 1)
    mavlink_system.compid = 1;

  2. Build and load the firmware with the above change.

  3. In QGC, set MAV_COMP_ID= 1
    Q > Vehicle Setup > Parameters > MAVLink > MAV_SYS_ID = 1

  4. Remove the temporary code change, rebuild and reload the firmware

Of course, this should not be necessary. It should be possible to edit or reset Parameters regardless of the Parameter settings, either using QGC or a separate program.

1 Like

Perfect that also worked for me thanks. Are you also trying to achieve RCb Override?

Hey guys, just as a quick fix you could also install Mission Planner, connect there and change the component ID back to 1 and tadaa, it’ll connect back to QGC once again. ,)

Can you be more specific because I’m also having this problem

I had the same issue, thank you so much for your solution

No i dont think this suggestion works. At least I cannot connect using mission planner (but I can connect using qgroundcontrol, just not change the component ID).