Make px4fmu-v2_default

#1

High I am running on widows and trying to use make px4fmu-v2_default but get the error “No rule to make target…” I am able to build using make px4fmu-v3_default and v4 etc. I see make files out there for this config, but I am not much of a make file guru. How can I get this rule enabled I need to build this version for Pixhawk 1 board with FrSky Telemetry enabled?

#2

You’ll need to use the master/developer version to get it. Unfortunately, it doesn’t start automatically in the latest v1.8.2. Go to my post here and follow the steps.

Good luck.

#3

I was able to work around this error, I read a section on updating the boot loader which enabled me to use V3 for Pixhawk. I then added the reference to the telemetry driver in the make file and was able to get V3 uploaded and the telemetry running through FrSky.

#4

Now that I have the FrSky telemetry working on TELEM1, it has disabled telemetry on TELM2. Now I have to figure out how to get them both working.

#5

I was able to get the telemetry enabled but the build of V3 default was giving me issues in that it said in QGroundControl that it was missing parameters and it was all ways giving me a High-low beep though the buzzer that never quit.

#6

Have you done all the calibrations and setup configurations? Follow the sequence of areas to do as listed on the left pane. With sensors, I usually go Gyro, Accelerometer, Compass, Airspeed (if applicable). Level Horizon is the last thing I do when the aircraft is completed.

Good luck.