Magnetometer Calibration not working for external mag on UAVCAN bus

Brandon Stevens 12:04 PM

I’m having an issue keeping my quad grounded - My setup is a generic quad with the FC being a pixhawk 4 and my GPS is a zubax gnss 2. It connects to the pixhawk4 over UAVCAN. I’m unable to calibrate the offboard compass on this GPS meaning the drone won’t arm itself. I can go through the calibration and it was fill in the offset/scaling factor for the pixhawk compass but will just list the ID and rotation of the zubax offboard compass.

if link broken

I believe it’s a known issue discussed here and wanted to see if anyone has any recommendations. I tried what the last user in that thread mentioned with offsetting the yaw to no affect

The px4 firmware on there is whatever the newest one is as of 10/18 that qgroundcontrol loaded on

Do you know more @PavelKirienko?

Still stuck on this issue, looking for any guidance. I tried nrodichenko’s suggestion here [ ]

but even after letting it sleep for about 9 seconds it still gives me the mag errors