Lidar Lite-v3 PWM not working

Hello, I have set up my lidar lite-v3 wiring correctly and have followed https://docs.px4.io/v1.9.0/en/sensor/lidar_lite.html in order to try to set it up in PWM mode in PX4. I enabled the rangefinder/port is enabled using [SENS_EN_LL40LS] - set to 1 for PWM but I still cant see it connected and see any data using analyze. The document said that my driver ( drivers/ll40ls ) may be missing but I do not know where to get it and how to add it to the board configuration. Is this the problem and how do I go about doing this?


image

Any help would be appreciated. Thanks

Have you flashed fmu-v2 or fmu-v3? It is probably not included in fmu-v2.

Also read: https://docs.px4.io/v1.9.0/en/config/firmware.html#bootloader

When I do the steps I start off seeing this and I select the developer master build.

I am trying to do the step after now but after every reboot nothing saves and I am completely lost. I get to step 3/4
to enable SYS_BL_UPDATE but the reboot takes me back to this and the update gets cancelled so I am taken back to the select build screen I dont understand how the SD card is working and I am wondering if that is the ploblem. I have tried it with the micro SD in the pixhawk and then my computer and both things give the same result. I dont know what to do next

I suppose you have done the bootloader update then and you really have a v2, so you need to either upgrade your hardware to something newer. Or you need to build PX4 yourself with what drivers and modules you specifically need.

you can enable/disable modules here:

Yes I think mine is a PixHawk 2.4.8 like the one in this kit. Does that mean I am v2? Does this mean I should use the v1.8 rangefinder setup guide or the v1.9-stable rangefinder setup guide?

What does building the PX4 myself mean if I need to do that, and where do I put the code that you gave me?

Thanks

@wboi check https://docs.px4.io/v1.9.0/en/config/firmware.html#bootloader

I can’t complete that step because the reboot resets the SYS_BL_UPDATE command every time I try to reboot it in step 4(“Reboot (disconnect/reconnect the board). The bootloader update will only take a few seconds.”) and there is no new hardware automatically detected.
Step 3 before reboot :


Step 4 (After reboot):

I assume that the bootloader update happens but you are stuck with v2.