Can't find SYS_BL_UPDATE pararameter in px4 fmu v3 firmware?

Hi I am using Pixhawk 2.4.8 it had Ardupilot ChibiOS as bootloader but it runs px4 firmware, I want to change the bootloader to PX4 as explained here

But I can’t find the SYS_BL_UPDATE parameter list from the list of parameters. As of now I am currently using stable firmware version 1.14

That’s not expected, both fmu-v2 and fmu-v3 should have the bootloader included according to:

Can you try running bl_update in MAVLink console in QGC?

You should be able to run:

bl_update /etc/extras/px4_fmu-v3_bootloader.bin

(or v2 depending on what you have).

Thanks for the reply,
I entered the command via MAVlink console it said bootloader is flashed successfully, but when I reconnected the usb (powersource) the board didn’t get connected with QGC. When I tried to reupload the firmware, it displayed detected device as PX4FMUV2 (here I am confused, I only entered the command to install the FMU-V3 bootloader). And the firmware upload be cancelled automatically due to the timeout issue from the bootloader.

I compiled the FMU-V3 bootloader from Bootloader repo, and tried to flash the bootloader via DFU mode in the Pixhawk 2.4.8. But the controller didn’t enter the DFU mode, i think it’s an hardware issue in my board.

So I replaced the Pixhawk 2.4.8 board.

Anyways thank you for your assistance @JulianOes

1 Like

Ok, that’s odd. Not sure what happened. But I always suggest to use an autopilot from a reputable manufacturer where you know what you get (e.g. Cubepilot or Holybro, or any of the other listed ones on Flight Controller (Autopilot) Hardware | PX4 Guide (main) but not the generic Pixhawk 2.4.8 clone which might not come with all sensors and certainly not with any quality assurances.

1 Like