Issue with Takeoff Mode PX4 Mini

My configuration: Flying Wing, Pixhawk PX4 Mini, Firmware PX4 v1.9.0,

I’ve installed and configured everything correctly.and my plane flies perfectly. My issue is with Takeoff Mode. In calm air, the Takeoff Mode works like a charm. I throw the plane and after about a few seconds the motor starts in full throttle and takes off. In the late afternoon, there was a 20km wind. When I threw the plane against the wind, the motor did not kick in. I assume that there is a minimum speed before the motor kicks in with full throttle. Which setting is it? Is there a way to reduce the time from 2 seconds down to 1 second?

Thank you.

I asume you are using QGroundControl.
I sugest to check this parameter list.

Look at the ## FW Launch detection

May be the issue was about the angle of pitch, or need to put a lower accelerometer threshold value.
Personally I shake and launch the plane after the motor reaches full throttle, that way I´m always shure that the motor spin up.
I hope to be helpful. Good luck.

Have you looked here?

Good luck.

Hi Tazman,

I made the following changes:

LAUN_ALL_ON changed from disabled (default) to enabled
LAUN_CAT_A changed from 30 (default) to 10

Removed the propellers and tested by throwing on to my bed. Works very well.

I am interested in this mode for 2 reasons: Want to avoid the props touch my hand during takeoff (back motor). Secondly, the plane only enters Mission mode if there is an auto takeoff. I put the plane in a Hold mode so it circles then switched to Manual mode then to Mission mode. For some reason it didn’t fly to the first way point. I restarted the plane this time armed with Mission mode, and the plane correctly launched and flew the 5 way points. Because where I fly we have strong valley winds, could not do Mission mode flying without a proper auto takeoff.

I now launch with Stabilize Mode with some elevator set by a radio switch. Even though, this freezes the elevator, the radio can still steer left or right during launch.

Thanks for your reply.