Fixwd-wing auto take off problem

Hi, everyone.
I had assembeled fixed wing Z-84 and confidently made some flights in manual mode.
The next step I can’t overcome is auto takeoff in catapult mode.
I can’t understand what does not allow to pitch up after a launch was detected.
The vechicle takes off from catapult and then tends down. Help me, pls see my log.

Hi @Rocket

Have you been able to takeoff autonomously yet? I believe the problem you have is that you need to be using a Takeoff waypoint in your mission.

If you want a handy way to be forced to remember this, consider enabling this parameter: MIS_TAKEOFF_REQ (enable or set to 1)

FYI @dagar @Kjkinney this is an example of why we finally need to get a fixed wing takeoff pitch parameter:

Hi @Antiheavy.
I haven’t reach autonomous take off yet. I am trying everything, but can’t achive a result. Here is a screenshot of my mission, where the take off point is at number two and is active.

@Rocket you say you’ve flown in Manual mode. Have you tried flying in Stablized mode yet? That is typically the next step. If the aircraft flies well in stablized mode, then you are ready to try some autonomous modes. Maybe you should try taking off in stabilized mode, then switching to Mission mode once in the air. If that is all working then you are ready for auto takeoffs. Did the flight log you posted above use a Takeoff waypoing?