Inconsistency while Tuning

I am using a Pixhawk with px4fmu-v2 1.8.1 firmware. I am tuning my quadcopter for a stability in the z-direction.
I am changing the MPC_Z_VEL_ parameters for tuning. I have uploaded 2 log files where the parameters are same but are showing different behavior in the log files.

I am unable why there is this difference despite the same parameters. Please help.

The complete logs:

Thanks in advance.

1 Like

Any suggestions?

What exactly do you see is different between the two logs? It’s hard to tell from your screenshots because the scaling is different in amplitude as well as in the time axis.

Both of your logs shows significant vibration in all direction as shown below.

Before tuning for altitude hold, you should tune for attitude and rate mode.
If your drone is unstable in attitude mode, you can never tune for alt hold nor position hold.

I also noticed that motors are not commanded evenly as they should. Below is from yours.

And here is from my drone.

You can clearly see motor 1 and 2 is commanded way more than 3 and 4 which means they are not calibrated unless you put different sets of motor and prop.
Have a look at Redirecting to latest version of document (master)
I personally prefer calibrating each esc manually with receiver.

Read carefully about settings of px4 and follow each step, you should get better stability.

Hey @Kyuhyong_You,
Yeah… There is a problem about vibrations. I have mounted the Pixhawk on the following anti-vibration pad. Still, this problem persists. What should I do to solve this?

Regarding the ESC calibration, I had done the calibration that is mentioned in your link. I don’t know why the problem is there. I will redo the calibration again to be sure.

Also, shouldn’t the Local Position z be constant when throttle is in the dead zone.


Hi @TrishantRoy

Your copter shows a large yaw control bias, this is why the output of the motors 1-2 are higher than the motors 3-4. This is most likely a rotor alignment problem.
A yaw control bias often produces roll/pitch stabilization issues due to coupling and higher vibration levels.
Other tips to reduce the amount of vibrations:
Don’t forget to balance your props; Mounting the autopilot on a soft isolation mount won’t magically solve all the problems.

Good luck

1 Like