Pixhawk4 Very Unstable in Altitude Hold Mode

Hi all. My Hexa Tarot680 is very unstable in Altitude Hold mode. I am new to QGC and need help interpreting the log. I notice very unusual motor thrust readings when in Altitude hold mode and large raw acceleration readings. Do I have a lot of vibration that is affecting the controller or does the motor thrust have to be tuned. Tx in advance


can u describe more “very instable”. if it is oscillatng on z coordonate it is a pid tunning issue. if you have drift on x-y axis it is normal, altitude mode doesnt control it.

it could also be interference on you gps. did you shield your gps/put it far from you camera/ESC. did you try flying in position mode ? in position, the drone should hover and hold position if you leave you rc untouched with sticks in the middle position.

you should concidere adding some damping material under your autopilot, you have to much noise on the accelerometer, but i dont think it is the biggest issue.

pid tunning probably

From the log file, it seems that you have high vibrations which explain why the flight is unstable.
Have you added damping material as Lyris mentioned?
Ensure you are using high-quality components as well (i.e. motors, frame, balanced props).

Not sure this reply got through so am resending it-
------- Forwarded message ----------
From: James Davies jaydaveez95@gmail.com
To: Marili noreply@discuss.px4.io
Date: Thu, 12 Jul 2018 09:02:22 -0400
Subject: Re: [Dronecode Discussion Forum, PX4, QGroundControl, SDK, MAVLink] [Flight Testing] Pixhawk4 Very Unstable in Altitude Hold Mode
Everything is high quality, props balanced, escs calibrated, etc. It flew beautifully with a regular Pixhawk2. I installed a new Pixhawk4 . I used the same dampening material on the Pix4 as I had used on the Pix2. I have lots of experience with the Pix2 (I have 5) but no experience with the Pix4. It seems like a vibration issue in the z axis from the z accel readings. Tx .

Try to change altitude hold p to 1.200 to 1.500 it solved the problem from me

I did notice from the log that it was hovering at 0.25 of throttle setting. I reduced throttle mid parameter from 0.5 to 0.25. It now hovers at 0.5 throttle position but still jerks up and down.

@jimid Can you please post a log with correct hover throttle parameter. I cannot analyze the first log you posted because the setting was still wrong.

Attached is my latest log. The throttle center has been set to 25%. This seemed to have corrected the jumpy Z axis oscillations. It also holds altitude and loiter very well. I still think I have excessive vibration. I also notice now , that motors 1 and 2 get quite hot after 10min. of flying. Any ideas what that is about?


Hey @jimid,
Vibration levels seem to be extremely high.
The noise then goes through the controllers to the motors, which is why they get hot.

Have you tried improving the vehicle setup regarding vibrations?