Vehicle Not Ready

Hello!
I am about to configure my first drone with a Pixhawk. Unfortunately I don’t get to the point that the quadcopter takes off and now I hope to find the help I need here.

Here are the key data of the drone:

  • Pixhawk 4 flight controller

  • PM07 Power Distribution Board

  • Pixhawk 4 GPS module

  • Holybro Telemetry Radio 433 MHz

  • T-Motor Air Gear 350 + matching ESC’s

  • 4S LIPO

  • FRSKY X7 Taranis Q
    bound with

  • FRSKY RX8R Pro

With the qGroundControl version 4.1.3 i have completed the firmware setup.
I chose “Quadrotor Wide” as airframe. I think my self-designed frame belongs in this category.
I configured all sensors (Compass, Gyroscope, Accelerometer, Level Horizon and Orientations) according to the manual. When I reboot the summary reports green for the sensors.
I finished the radio setup (Mode 2). If I move the transmitter’s analog sticks, everything also works correctly in qGroundcontrol.
I configured the transmitter with OpenTX Companion. SF is supposed to be the arming switch. In QGC I went to Multi Channel Mode Selection. Here the configuration looks like this:

Switch SC

  • Stabilized / Man (Channel 5)
  • Assist (Channel 5)
  • Auto (Channel 5)

Switch SD

  • Altitude (Channel 6)
  • Position (Channel 6)
  • Mission (Channel 8)
  • Hold (Channel 8)

All others are disabled. If the drone is connected via USB and the transmitter is also on, the flight modes can be switched cleanly.

I chose Power Module within the Power Setup. The number of cells is 4. Empty Voltage and Full Voltage are set to the default values ​​3.5 and 4.05 V. The voltage divider was calculated and has the value 18.75386429. I have not configured amps per volt. Here the value stands at 36.36751556.
“Show Advanced Settings” is not selected.
Battery 2 is disabled.
The ESC calibration is complete.
“Show UAVCAN Settings” is selected. UAVCAN bus configuration is set to “Sensors and Actuators”.
I have not yet carried out a UAVCAN Motor Index and Direction Assignment. Do I have to do this? Does the battery have to be connected for this? When I click on “Start Assignment” I get the error message “MAV_CMD_PREFLIGHT_UAVCAN command failed”.

Nothing happens under “Motors” without installed propellers.

With these settings, connected radio to drone and PC, in the living room, QGroundcontrol reports “Not Ready” in the top left right next to the QGC logo / button. GPS and Pre-Arm Check are set to Error here.
My idea was now … Go outside and see if the GPS works outside and then the pre-arm check. Unfortunately negative. QGC reports various errors. “Battery” and “AHRS” now also read “Error”.
Is it normal that I don’t get a log within “Analizing Tools” before I was able to fly?
I hope I have described everything necessary. Maybe someone of you has solutions to my problems. In any case, thank you for your interest!

Regards ChO

Changes:
I realized that it makes no sense to activate UAVCAN in my setup. So I turned it off. I set the voltage divider to default.

Here is the last log that I wrote. Unfortunately the engines are still not running.

https://review.px4.io/plot_app?log=68ab25a9-e527-4410-bcc6-fa3430d6f9a2

News:
My problems are largely resolved. My mistake was probably that I only pressed the switch button briefly and not long enough for the pixhawk to respond with a signal.
Is there a way to listen to acoustic signals from the pixhawk on the web? Is there a list of acoustic signals and their meaning? If not, that might be something that could be added to the documentation …

Did you get a reply for these issues !!