Holybro X500 V2 Quadcopter ESC Setup

I just bought a Holybro X500 V2 quadcopter and a Holybro 6C Mini flight controller. My understanding is this quadcopter comes with 20A 4S BL-HELI_S ESCs. I am trying to figure out how to install Ardupilot firmware in this quad. QGroundControl has an icon for a Holybro X500 V2 quadcopter but no information on calibration of the ESCs. Arducopter and Mission Planner do not have a specific Holybro X500 V2 quadcopter frame listed, and their documentation discusses a pass-through procedure for BL-HELI_S ESCs which I do not understand. All I have worked with in the past have been SimonK ESCs. Can someone tell me how to set up this quadcopter with respect to the ESCs? Holybro provides no information. Should I set this quad up in Mission Planner or QGroundControl?

For ArduPilot, consult the Ardupilot forum. If you are using Dshot then you don’t have to calibrate the ESC. ESC calibration is required for PWM and OneShot.

If you are using PX4 and PWM, you can perform ESC calibration according to this.

I installed my Holybro Pixhawk 6C Mini on my Holybro X500 frame using firmware 4.3.1 on Mission Planner. There was a pull-down menu specifically for this aircraft which uses 20A 4S BL-HELI_S ESCs. I set the quadcopter up per instructions, and it worked just fine. Recently I had the quad on the laptop, and Mission Planner said there was a new firmware 4.5.1 and asked me if I wanted to upgrade. I agreed and installed the new firmware. Now the pulldown menu for a Holybro Pixhawk 6C Mini on a Holybro X500 frame is gone, and I can’t get any response out of the motors. The aircraft will arm and there are no errors, but the motors will not spin up. The Servo page in Setup shows all motors stuck. I tried calibrating the motors, but that did nothing. I’m clueless. What’s going on?

As mentioned earlier, this is PX4 software forum. You are using Ardupilot software. consult in Ardupilot forum.