HIL Simulation Problem with XPlane 10

Could i get a little help from you?

I want to use simulation with XPlane 10 and pixhawk. For my purposes i tried to use some of QGC classes (QGCXplaneLink, Vehicle, FirmwarePlugin and others) and wrote my own xplane2mav proxy, which converts MAVLink packets to UDP datagrams for Xplane and vice versa.

Seems that i copy and paste all what is needed for simulation But since i cannot even take off, i think that i forgot something important. And if you have a time, i’ll ask you to help me a little.

So, what i’ve done.

  1. Connect to pixhawk (with required slots and signals)
  2. Connect to XPlane (with required slots and signals)

After these 2 steps i am able to receive plane params from XPlane and send it to px4. Then i’m trying to take off as follows:

  1. Change flight mode to Hold
  2. Send MAV_CMD_NAV_TAKEOFF command

After doing that px4 begins to send MAVLINK_MSG_ID_HIL_ACTUATOR_CONTROLS messages, which i’m forwarding to XPlane. But result doesn’t correspond to the result i want to see. Plane starts to move, sometimes it climbs in air but falls at once. I have no idea what i’m doing wrong.

Sounds like the breakdown is the actuator commands you’re sending to xplane? Are you planning to make xplane2mav open source? If so I’m sure there are other people interested in it that may be able to help.

Problem solved. I forgot to initialize variable xplane version. xplane2mav open source? If the authorities allow. Not everything depends on me.