Cannot control airplane with radio AT9s in HIL with Xplane 10

#1

I tried to do HIL by following this link: https://dev.px4.io/en/simulation/hitl.html
I selected HiLStar17 in Xplane 10. I connected Xplane 10 with QGC 3.2.2 (around 19 Hz) by using Pixhawk (PX4 firmware 1.6.5). Everything worked well until I armed on my radio, airplane in Xplane 10 just go automaticly roll right for eternity ignore my command from radio. What should I do to fix this? help me please. Thank you.

1 Like
PX4 HITL xplane bug?
#2

Bumping. Definitely having this issue as well with:

  • QGroundControl version 3.2.2 & Daily Build 2017-08-15
  • Windows 10 (Anniversary Update)
  • PX4 Flight Stack stable release version 1.6.5
  • 3DR Pixhawk 1 board
  • Futaba R8014HS RC Receiver
  • Futaba T10CAG 2.4GHz RC Trasmitter

Anyone have any idea what’s happening with the HIL mode? I checked using QGroundControl’s Mavlink Inspector and found the HIL_ACTUATORS_CONTROLS had all channel values to 0 except for the Kill Switch (which I set up to Channel 8), RTL Failsafe Switch (set to channel 5) and for changing flight modes (set up to channel 7–a dial). Attached is my attempt at flipping the Kill Switch and controlling the plane,
which Mavlink detected that only the Kill Switch value changed (0.5 to 0).

Since I’m using Windows, I can’t really make a custom firmware with the guide available on dev.px4.io (the windows_bash_nuttx.sh immediately failed to replace any Linux command since it’s using sudo itself). Any help would be appreciated.

#3

hello ,i am chinese.i have the same question as your.i search in chinese network,but i couldn’t konw how to solve it.i want to know have you solve the question ,and how to solve it ,thank you very much.