GPS self-jamming/EMI


We use pixhawk 2.1 and Ublox NEO M8N GPS module.
In this simple configuration GPS reports lots of satellites and EKF2 gets GLOBAL_POSITION within ~15 seconds from boot.

But things go downhill as we add more stuff to the drone. We connect Intel NUC as on-board computer, RPLIDAR, Intel RealSense ZR300. As more devices are added (or even wires re-arranged) we see all sorts of problems with GPS.

First problem is when GPS driver report zero satellites. This seem to be caused by simple RF interference. So moving GPS away from all the main electronics helps with this.

But there seem to be another, more insidious problem with conductive noise.

The issue was discussed in 2012 here:

and at more length in 2014 here:!topic/drones-discuss/VpQe2t4juk4

We managed to trace some interference to serial communication on TELEM1/2 causing noise in the power cables going close to pixhawk. After moving the cables away from pixhawk we see less issues. Also played with putting ferrites on various wires with some success.

BUT seemingly trivial changes to any part of the system tend to throw GPS out of order now. Or cause EKF2 to take minutes to get GLOBAL_POSITION.

For example swapping cameras from Logitech to RealSense to MyntEye gives unpredictable GPS performance.

What is the current state of the game with GPS self-jamming on pixhawk hardware? Any advice?

I would imagine lots of people use Pixhawk/PX4 in progressively more sophisticated configurations and must encounter these EMI issues.

This is typical and something not easy to master. It would require working through all peripherals - which is why we’ve built the Auterion reference design, which solves all these issues:

USB 3 is likely the problem, just search for GPS interference and USB 3.

1 Like

@JulianOes, thanks! This is what we see, at least with RealSense.

@LorenzMeier, thank you for confirming! Would still be interesting to see if there is any combination of open source hardware that can work together and not interfere with GPS.

@LorenzMeier I see you use FMUv5-based flight controller on Auterion solution. Would you comment on whether pixhawk4 would have some of EMI issues handled vs pixhawk2.1?

I suggest you try to use USB 2.0 as well, USB 3.0 does not work at all together with GPS in my experience.

Same experience here. Stay away from using USB 3.0 interfaces.

Many digital video cameras, WiFi devices, and anything with ethernet on it often are terrible gps jammers.

Hello @JulianOes @LorenzMeier @Antiheavy @alexs512 @lamping.ap @bkueng
I am using pixhawk 4 with its official GPS module I am also facing GPS issue for long. Sometimes it works and sometime does not. I am also usign rpi on the UAV that is connected to my laptop using wifi.

Can wifi act as GPS signal jammers. If not , the what could be that reason for inconsistent GPS performance.


I have not worked with this for some time. But my advice would be either go with a complete platform where RF interference issues have been solved or employ someone who can debug this on hardware level.

Kind Regards,

I doubt WiFi is the issue, but you can simply turn it off when you’re having problems and see if the signal improves.

as far as i remember in our case USB3 camera connection was the issue. it created some RF interference for GPS.