Tuning F450 rate gains and flying indoors

I am using pixhawk-4 and px4 v1.9.0 to fly my drone indoors using vicon. I have few questions if you could take some time to look into it.

  1. I was using v1.8.2 before and was getting msgs on QGC screen that you are using an old firmware so I switched to v1.9.0. However, now repeatedly I get a red error msg saying “data link lost” or “onboard controller lost”. Can anyone tell the reason for that. This doesnt stop it from flying though. I tried to revert back to v1.8.0 but then could not get the vehicle connected to QGC so using v1.9.0.

  2. Please see a log in which I just hovered the quad. https://review.px4.io/plot_app?log=8e3d117d-9fde-4008-b401-ca54c7c0988c.
    I have a NUC onboard and am using my version of geometric controller, that subscribe to vicon data and send rate commands and thrust to the quad. The estimated and setpoint rate do not match well. It might be a tuning issue but so far my tuning did not result into a better result. Moreover the setpoint and estimated yaw are 90 but my quad is placed in a way that the vicon has yaw = 0. I can understand this difference.

  3. Please see the vibration data also, the quad vibrates more at low frequencies which I want to reduce. I tried graupner E props and balanced them and also dji props that look very good balanced off the shelf. It has Emax 2216 810kV motors. The total weight is around 2kg. I am not sure if this information is enough but can anyone think of a reason for these vibrations. I will be happy to share any other detail.


  1. Presumably this means that sometimes the MAVLink connection to either your onboard computer or a ground station is lost. Is that possible?

  2. I’m confused about your vicon setup because you also seem to have uBlox GPS input? And looking at the log I see that the jamming indicator has weird jumps. Regarding yaw you need to check what the EKF2 is using, is it based on the mag or on your vicon input?

  3. The vibrations don’t look terrible from looking at the log. Not sure what to suggest.

Hi, Thanks for the reply. I suspected the mavlink connection but it suddenly started behaving so with the v1.9.0. I was using v1.8.2 before and have never had any issues. I tried to revert back but then could not connect the vehicle with QGC so used 1.9.0. I have another vehicle that run 1.8.2, I will fly that today or tomorrow and tell if I observe the same.

About the Jamming. Is there a way to just switch off GPS. I did not know that I was getting GPS signals indoors. what does that weird jumps indicate. I tried to search about it and got few posts about GPS signals getting messed up when you put things on the drone. say USB3 cables. I can not avoid it as I have two pointgrey cameras on it and both need USB3.0 cables. The GPS module is also mounted close to NUC.

One thing that I want to point if that could be the issue. I do not connect to Telem2 port. I just use the usb connection and run mavlink on ACM0. This is because I wanted imu data to be at 200Hz and in my previous setup I got that only when I set fcu_url at ACM0 and echo HIGHRES_IMU at 200 in extras.txt

Never got imu msg at more than 50Hz with telem2 and ttyUSB0. Now in v1.9.0 there is no sys_companion so I do not know if my baudrate for ACM0 is high enough. I would really appreciate help about this.

I’m not sure if/how you can disable the GPS if not plugging it out completely but then you also lose the external mag.

For the config of serial ports such as Telem2, check the instructions in: https://docs.px4.io/en/peripherals/serial_configuration.html