Flyaway with no manual control

I’m not sure where this post belongs, so I will start here.

Situation: I was flying a F550 hexacopter with Pixhawk 1 running PX4 v1.8.2. It was checked out on the bench for all flight modes and everything was working. When I went outside to fly it, I checked out all functionality on QGroundControl, and watched the screen as I switched between all flight modes and they all appeared on the screen. GPS had 20 satellites. The Pixhawk light was green. Everything appeared to be good. I powered up, armed it in MANUAL mode, and I made a short flight to confirm everything was airworthy.

On the ground, I put it in ALTITUDE mode, took off and let it hover at 20 meters. Then I switched to POSITION mode. Instead of hovering in place, it started to move away from me and started climbing. Immediately I changed to MANUAL mode and tried to regain control. Nothing happened. Changed to STABILIZED mode. No help. Tried ALTITUDE mode. Nothing. Then I hit the RTL switch. No response. It kept moving steadily away. Then I tried all the flight modes many times but there was absolutely no response from the drone. I watched helplessly as it went out of sight. I watched the path on QGC. It was traveling towards a highway and a highly populated area, so I put the throttle in max position hoping that would keep it high. Altitude eventually went to 800 meters, yet nothing I did with RC control did anything to get it to come back.

Eventually I lost telemetry and data stopped. It was then at about 120 meters and coming down slowly, and the battery was very low so I knew it would be on the ground soon. The last known position was noted and we went to the area to look for the drone. This is a heavily wooded area, and after looking for it for a few hours, we have not found it, and may never get it back. Hence no log files are available.

One thing I remembered from the pre-flight checks was that I could not arm the drone in POSITION mode, but I thought that was not allowed, so I ignored it. In retrospect , maybe that indicated a problem.

Can anyone offer any ideas as to why this drone ignored MANUAL RC control?


UPDATE: We found the missing drone three days after it crash landed. The log file has been downloaded but its too large to be uploaded to Flight Review (325 MB).

We’re analyzing the ulg file and trying to find the cause, but it would be great to be able to see all the graphs and flight modes. I posted this issue in another forum. But I’d still like to know under what circumstances PX4 will not respond to MANUAL RC control??


Hi Joseph,

After reading your post … what happened to you happened to me.

Today was my maiden flight of an S500 quad-drone and all was going well did a few stick movements to see how the bird handled and decided to land for a checkout - WHEN! - all of a sudden the drone took off vertical … did not have any stick control what so ever and the only thing I could do is watch it go into the air and start moving south THEN gained control on my Rx … Tried to land again and lost control of it again … Finally, it landed abruptly falling on one side where I could pull the battery power. Did not hurt anything but sure scared the hell out of me … I have flow RC for over 30 years and this was my first run away … especially being a drone with a PX4 unit attached. To be honest I’m starting to feel a bit weary using a PX4 and QGC - It’s getting to the point someone has to convince me that these two platforms are really worth their weight in price and performance.

UPDATE: After a lot of work pouring over the logs, we discovered a few important things. First of all, the Rx was defective. On the ground it failed the range test, so now I know why I lost manual control when it got a certain distance away. Second, we were trying to use two compasses for the first time. The two were not giving the same readings to PX4, so it had to ignore them. That doesn’t work too well. It doesn’t have any direction reference. Then the EKF2 system can’t decide where it is and goes into failsafe mode and brings it down.

Another thing … when you are using manual control to fly, you can loose it IF the firmware thinks there is a fatal situation (ie, battery is dying, or it doesn’t know where it is), in which case it goes into failsafe mode and takes manual control away from you.

We now tether our drones for all experimental flights, and it has saved my butt a few times.

I too have had a few hesitations about using PX4 and QGC, but there is no panacea, and this environment is very good, backed by Auterion developers to make it a robust open source system. I’m staying with it for now.


Thanks for the update, Joseph…

I’m not running dual compass systems just standard everything … until I can get this bird where I need it then start my modifications.

However, with that in mind, I do have all of my fail-safes are in play… Everything checked out prior to flight … battery, motor start, etc … all checked out. I agree if there is an issue the fail-safe mode will take over manual control … Which is what I am starting to think happened.

The only thing I need to figure out is which one?

I tried to upload my ULG file online to PX4 for review. Unfortunately, I get a 400 FATAL ERROR when I try to upload the log file on PX4 log review site. I need to contact someone with the PX4 team to email my flight log for them to review. Hopefully, the information will allow me to determine the cause of my flight issue. Never know it may have been like yours with the Rx … not real fond of the radio I’m using. What is a bit ironic is when you mentioned the Rx being bad. What I found has been a bit on the strange side is when connected to QGC on radio telem with the Tx and Rx up and running … There have been times I lost connection just sitting on the workbench.

I totally understand the fact of being a robust open-source system and having to stay with it now … I plan on staying with it mainly due to the cost I had to spend for the product yet I am maintaining a product journal of the Pro’s and Con’s.

Waypoint …
If you can’t upload a ULG file to the Flight Review app, then it may be too big. I had a 341 MB file that would get the 404 error, and it never would upload. However I just uploaded a 130 MB file and it took.

Relative to loss of manual control, anything that causes the Pixhawk to lose global position will trigger a failsafe. Any one of a number of conditions will cause this. You need to check your message log to see what is happening. If you can’t access Flight Review, look at other flight log programs like PlotJuggler . It parses ulg into csv files and lets you look in detail at every parameter, including error messages.

Good luck