DJI F550 Flyaway

I had a wild experience with my DJI F550 hex with a Pixhawk Mini, and I could use some help from this forum to understand what went wrong.

This drone has flown successfully in 4 previous flights, validating the unassisted and assisted modes: STABILIZED, ALTITUDE, POSITION, and HOLD, and they all worked perfectly. I then put it into a MISSION mode, to test auto flight. It flew that very well. When the MISSION stopped, I tried to land it by putting it into the STABILITY mode. When I did, it accelerated upwards and I had no response from the sticks. I switched to ALTITUDE mode, but that made it race forwards away from me, again no response from the sticks. By then it was going out of sight, and I tried changing modes again to no affect. Finally I put it in RTL mode, but because it was no longer in sight, I didn’t know if it was working or not. Several minutes later it returned home at high altitude, and started to descend, but by then the battery was dead and it came in hard and broke two of the landing legs.

I have looked at the flight logs and discovered that after the mission completed, each time I put it in STABILIZED mode, it climbed rapidly, and when I put it in ALTITUDE mode it raced ahead away from me. I had no stick control during the entire outward bound path. Fortunately, the RTL mode brought it back autonomously.

Could someone please look at these logs and tell me why did STABILIZE make it climb with no control, and why did ALTITUDE make it go forward, again, with no direct control. I believe there is a battery low issue with this flight, but why would the Pixhawk tell the drone to climb rapidly when the battery is low and it should be time to land??

This is a link to the Pixhawk Flight Review I have been looking at.

This is a link to the actual file on Google Drive

Thank you