Fly/Action button greyed out - always

Hi Guys

On the Android version (perhaps the others too) the Fly/Action button remains greyed out even after successfully arming and take-off.

Is some condition not being met? What am I missing? It’s a bit scary with a big UAV up there and no visible way to proceed (other than the limited pull down from the top line).

Thanks in advance

If you aren’t using a Daily Build of Android try that instead. If not, what firmware are you using?

Sorry, I should have provided more details:

PX4 v1.7.2
Latest QGC from the Play Store, and I also tried Daily Build.

I’m using the ESP8266 WiFi module, built and flashed from sources here:

I’ve used the ESP8266 for telemetry to QGC / PX4 and controlled and flown successfully before, but using a much older version of QGC. The one where you could dial up altitude on a slider on the RHS.

Yesterday, as a new development, I got this error message from QGC on Android 7.0 on a Samsung 9" tablet: “Unable to takeoff, MIS_TAKEOFF_ALT parameter missing”, this using the latest stable version, and not daily build. Perhaps the telemetry was compromised on the day?

Previously I could arm and take-off, but the Fly/Action button remained greyed out.

Without wishing to complicate matters, I’m also separately testing WifiBroadcast, a medium-range best-effort two-way WiFi UDP telemetry/video approach using Raspberry Pis. My attempts to control the remote craft produce the same results with the PX4/QGC setup as with the ESP8266.

Essentially what I need to know is why the Fly/Action button remain greyed out, without delving into the code.

Thank you for your kind assistance.

It is very strange that you would get an error about MIS_TAKEOFF_ALT missing. Did parameter load complete without errors?

Some things to know about the Action button. The only things that show up being that are:

  • Start/REsume Mission - only available if there is a mission on the vehicle and you are not currently flying a mission
  • Change Altitude (only available when you are not flying a mission)
  • Land Abort (fixed wing only)

What are you expecting to be available?

I solved the MIS_TAKEOFF_ALT missing problem and can confirm it’s unrelated to this issue.

I simply (initially) want the fly the craft, not carry out a mission (yet). This to prove that Mavlink commands are all being received correctly, then we can confidently extend our range and start flying missions.

So to fly, we need to take off, climb to altitude, have craft fly as commanded real-time, then RTL.

With the older GUI I would use the Change Altitude button in the box at the bottom of the screen, and then once at the desired altitude, touch the places on the (android tablet) screen I want to go, and then RTL.

Since the Fly/Action button is always greyed out, I can’t access the Change Altitude command embedded there. Nor any of the other commands other than those from the top of the screen pull-down.

I’ve done the same tests using an ESP8266/WiFi link which I have used successfully many times before with the old GUI. Same result.

A new Daily Build arrived last night, and I’ll try it later today if time permits.

Thanks again for your kind assistance. I hope I’m not missing something obvious.


The current user guide, under the Fly heading, describes the Guided Bar, now apparently removed?:

Guided Bar
At the bottom of the view is the Guided Bar. The guided bar allows to to interact with your vehicle directly from the QGroundControl application. Options available vary by Vehicle and current Vehicle state. +

Some of the possible options are:
Arm, Disarm, Emergency Stop
Change altitiude
Go to location

I"m going to need to turn on some debugging stuff in a build to figure this out. Can you move this to a QGC GitHub Issues and then we will continue tracking it down there.

Done as requested. Thanks