Fixed wing problem (vtol cfg)

Hello.
Configuration is next - wing with 4 copter motors and 1 pusher.
Connected like in manual:
SYS_AUTOSTART = 13006
MAIN1: motor 1
MAIN2: motor 2
MAIN3: motor 3
MAIN4: motor 4
AUX1: Right elevon
AUX2: Left elevon
AUX3: Motor

In copter mode fly perfect, but in fixed wing a lot of problems.
First problem - seems that Pitch and Roll is inversed, when I press pirtch UP, elevons goes left, Pitch DOWN, elevons goes right, if I press roll LEFT - elevons goes UP, and so on.
But in copter mode - everything is FINE.

Second problem - I can not arm motor in fixed wing mode, after switching to this mode copter just turn of motors and fly down.

video - https://youtu.be/XlSpz23x5mk

  • What firmware version are you using?
  • If you’ve calibrated your Radio Tx correctly, then you may have crossed the servos. Try switching them around.
  • What are your settings for the following:
    – VT_TRANS_THR
    – VT_F_TRANS_DUR
    – VT_TRANS_MIN_TM
    – VT_ARSP_TRANS

Good luck.

Servo problem already fixed.
Firmware 1.7.3 stable.
VT_ARSP_TRANS 5
VT_TRANS_MIN_TM 2
VT_F_TRANS_DUR 5
VT_TRANS_THR 0,6


Last flight log - https://review.px4.io/plot_app?log=a0e62636-4a9d-4c74-bec4-aacc9cd37da9

In flight copter motor turned off, but pusher not start.

Please don’t be offended. Just making sure all bases are covered.

  • For some reason, I can’t open the link you provided.
  • Have you calibrated the ESC by itself, directly connected to Rx, independent of the Pixhawk?
  • Does motor respond to throttle from Tx when ESC is plugged directly to Rx?
  • Check and make sure that the ESC servo plug to the Pixhawk is in AUX3 and not upside down (signal wire down).
  • With props off and on the bench, in Stabilize mode, arm and start the quad motors then switch to FW mode. Does the pusher motor turn on? If not, maybe there’s something wrong with ESC or the motor itself.

Good luck.

Have you calibrated the ESC by itself, directly connected to Rx, independent of the Pixhawk?

yes. esc calibrated, but when I power on the VTOL it beeps all the time (tomorrow will record a vide[quote=“rollys, post:4, topic:6738”]
Does motor respond to throttle from Tx when ESC is plugged directly to Rx?
[/quote]

yes.

absolutely.

in stabilize mode, I arm copter motors, then switch to wing mode, and blow to ASPD, copter motors stoped, pusher not start, elerons - working.

Tomorrow all situations try to film.

Thanks for helping.

This means that the ESC is not receiving signal from the Pixhawk. Make sure ESC servo wire is connected to AUX3, if it is, try AUX4 or AUX5 or even AUX6; whichever one that makes the beeping stop. If it stops beeping, then test to see if it works. If it doesn’t stop beeping in any AUX port, take a close look at the PWM pins of the Pixhawk to make sure none of the signal pins are bent. If all is good, then try a different ESC.

When it arms in MC mode and quad motors start spinning, move throttle to 1/4-1/2, then switch to FW mode, the pusher motor should immediately start. The fact that your pusher motor ESC just keeps beeping when you plug the battery indicates that it’s not getting a PWM signal from the Pixhawk.

Good luck.

The problem is solved. But there is a new one.

When I arm - pusher motor starts with copter motors, when I switch to FW mode - copter motor stops.
Also I can arm in wing mode, but disarm only in copter mode.

What was the problem and what did you do to solve it?

That’s clearly not correct. What AUX port did you plug the ESC signal wire to?

…without blowing into the pitot tube? You didn’t disable the airspeed sensor, did you? FW_ARSP_MODE = Enabled

Yes, I believe that’s the way it’s designed to be; arm and disarm in MC mode. Think of it this way, when in FW and you want the aircraft to glide down, the pusher would be throttled to zero/off. You wouldn’t want it to disarm because your quad motors won’t respond if you switch to MC mode or if you quad chute is active, it won’t recover from a stall or spin, for example.

Good luck.

5 ESC were with BEC, and in pusher motor it was broken, so when I put it on servo tester - it works fine, but when I connect pixhawk AUX out - it not works. Change BEC to another motor - everything became good)

also solved. Was my mistake.

And… everything flight perfect)
Thanks a lot for helping!

Excellent! Would be great if you can have video of the flight tests.

Good luck.

soon will post. I made this wing just for test of transition.
Tomorrow will start build x5 pro vtol, and will film flight.
thanks a lot!

Hello guys :relaxed:
I also having a problem with my VTOL project. In multi-copter mode it works well but when switched to fixed wing then it is not working (any of the servos and tractor motor as well) I mean my AUX out puts does not work.
It should move the servos (which are plugged in AUX out of pixhawk ) in copter mode as well in fixed wing mode but in my case those are not working either in copter mode or fixed wing mode. I checked both of the methods to plug tractor motor (fixed wing) in AUX 3 as well as AUX 5. But my issue is not solved servos have a power but halt in their mean position. I totally followed by the manual of Fun Cub Quad but my issue is still there please help me.

Thanks and waiting for reply . . .

  • What airframe did you choose in the initial setup? Verify the outputs accordingly.
  • Did you press the safety button first then switch to FW mode?

Good luck.