FAILSAFE mode activating constantly after the vehicle enters the OFFBOARD mode

System Configurations

OS: Ubuntu 18.04
ROS Distro: ROS Melodic
PX4-Autopilot branch commit ID: faca2b17d0b0259ba5083827d858510648cf45a9 on Sept 17, 2021
image

Build Status: Build successful, could see the drone in Gazebo simulation after I run make px4_sitl_default gazebo

Issue

When I launch the launch file mavros_posix_sitl.launch inside PX4-Autopilot/launch it works perfectly fine and I could see the drone as well in the Gazebo simulation.

The status of MAVROS also appears to be “connected” when I echo the data on the ROS topic /mavros/state

But when I run the offboard control example node from the official documentation of PX4, there is a hustle between the FAILSAFE and OFFBOARD modes. Every time the controller goes into OFFBOARD mode the FAILSAFE mode activates and is deactivated constantly. This makes my drone unable to arm and fly.
image

If there’s any more information I need to provide please let me know. Help is appreciated, TIA.

I am experiencing the same problem. Have you found a solution to this yet?

I had a similar Problem where the Failsafe apparently was engaged by “No manual control stick input” which was not printed but stated in the log data.

like recommend here ( ROS2-PX4 OFFBOARD triggers Failsafe enabled: No manual control stick input - PX4/PX4-Autopilot ) entering “param set COM_RCL_EXCEPT 4” not fixes it but deactivates this safety measure.

I ended up changing it directly in the drones config.

buddy I got the same situation, fixed here Failsafe mode keeps activating and deactivating - #2 by JaimeParker

Which version of PX4-Autopilot are you using?

I have tested a lot of possibilities here and with the last release (version 12) I have this problem, the drone stays in fail safe mode and it doesn’t take off. A friend of mine tested the same commands on his PC and works, so we tried to step back in the version, now I’m using version PX4-Autopilot 11.3 (the last version that worked for me) and it is working fine now!

To flight using commander directly the PX4 it is needed to define the takeoff point to avoid error. To flight using script you just keep the position and the drone stays stable!

About the PX4-Avoindace I haven’t success to run on my actual PC.

OS: Ubuntu 18
ROS: Melocid
Gazebo: 9
PX-Autopilot: 11.3.0