Failsafe enabled: no global position estimate - help explanation error


I’m new to drones and I’m trying to fly a custom drone from my laboratory through Qgroundcontrol. I’m just trying to take off and holding the position for an infinite amount of time (until I press land). I installed the PX4FLOW Smart Camera (because I want to fly indoors, I set up the Extended Kalman Filter (EKF2) equal to 2 so only “use optical flow”). First of all, I did a test outside and once the drone take off, after some seconds, the error “Failsafe enabled: no global position estimate” pop up causing an automatic landing.

Any idea why is this happening?


As the error message says, it has no global position estimate. This typically happens when you have a GPS that loses signal for too long, so it loses its estimation of where it is. This causes the drone to be unable to hover as you are trying to.

@Mr_Madsen thanks but I intentionally disabled the GPS through the parameters EKF2 because I would like to do the next flights indoor. How can I avoid this emergency landing with a disabled gps?

Not sure if you have already disabled the GPS :thinking:
Maybe it hasn’t been disabled properly.

@Mr_Madsen do you know how to disable it properly?

Not sure how to do it using software if disabling it in the EKF2 didn’t work when you tried. Maybe you can simply unplug the GPS, if you are not going to use it. This should do it.

I already tried unplugging the GPS and it is giving another error related to the fact that it can’t find the compass. So the GPS must be connected to have the compass connection

What flight controller are you using? I mainly have experience with the flight cubes, which has internal compass.

@Mr_Madsen I’m using a Pixhawk mini