ERROR [simulator_mavlink] poll timeout 0, 0

Hi! I’m using PX4, Mavros,Airsim and UnrealEngineSimulator. UnrealEngineSimulator is executed in Windows 11 and the rest is executed in Linux 20.04.

after some simulation time, I get this error in the PX4 window:


But there comes a point that the connection between PX4, mavros, Airsim is closed with the simulator:


Can anyone know why this error occurs? It is closed by the Airsim parameter in the settings.json “Lockstep Simulation”, how can it be solved?

Thanks in advance. Best regards

This would happen if a message between PX4 and simulator ever gets lost and hence it gets out of sync/lockstep.

Have you tried disabling lockstep?

Yes, disable lockstep in Airsim settings:


However, I keep getting the error

Have you also disabled it on the PX4 side? I’m not sure if you have to but I’d try it.

I have disabled Locktep in PX4 by following PX4 Lockstep - AirSim . I also change the “ClockStep” param in Airsim to “”.

And the vehicle is not able to take off with the px4 takeoff command and ends up crashing to the ground. I don’t know if it has something to do with the scheduler time.

I would ask someone that maintains AirSim.