Error messags log files

#1

Hi,
I have an Intel Aero RTF running ubuntu.
I’m trying to find a solution to get the log files from the drone but there is a problem with it as you can see in the following picture :


Firstly I tried to get them on my groundstation (W10) but after a lot of research I was not able to find a solution. Of course I clicked on refresh but nothing… I tried through wifi hotspot and ethernet-over-usb but nothing. I also tried to get them from Mavlink 2.0 Logging and nothing appears. I receive the information of the battery, GPS etc but not the log files. Moreover, the loss rate is around 20% on the ground station and 5% on QGC running on the Intel Aero directly.

Two main error messages appears:

  • MAVLinkLogManagerLog: Start MAVLink log command failed. --> by start logging on mavling 2.0 logging

  • LogDownloadLog: Request log entry list ( 0 through 49 ) --> by clicking on refresh

Can you help me please? Thank you :slight_smile:

#2

@bkueng any idea what is wrong here?

#3

The Intel Aero does not have persistent storage for logs on the autopilot. Instead it streams the log data to the Linux companion. You can get via scp, they should be stored in /var/lib/mavlink-router.

1 Like
#4

Thank you!
Is there a way to get them directly on QGC? By streaming them via UDP or sending them through ethernet-over-usb?

#5

I think you could stream them, but you will have to disable logging in the mavlink-router config.