Detected 0 radio channels. To operate PX4, you need at least 5 channels

Using QGroundControl, I tried to do the radio setup with my pixhawk. However, the message in the topic shown.

I’m using the WFLY WFT09II with the WFR09S receiver along with PPM encoder.

No motors are connected. (BTW the IO B/E & ACT LED kept flashing police light)

Thank you for your time and attention

I had a similar problem with a micropix (reduced sized pixhawk clone). I was compiling from the repo version of 1-2 weeks ago. Then I updated the local repository to the latest changes , compiled again, and now it works. Another possible problem that I read at , is that you must make sure that the firmware is correctly updated in the pixhawk.
While trying to figure out what was the problem, I used a spare APM that I had lying around to check that the PPM encoder is working correctly. If you have one, try to check if the PPM signal is correct, or you could also use an oscilloscope to see if the signal looks correct.
In case you have the same PPM encoder as I do, it should initialize with a solid blue led and then start blinking fast when the TX is turned on. If you turn it off, it should blink with a lower frequency .
Hope this helps.

Thank you very much for your help.

However it keeps happening even though I tried to update the firmware.

Do I need to set things in the radio transmitter? I already set it to the ACRO and PPM mode.

-Hold press the arm/disarm safety switch while plugging in the Pixhawk. Keep holding the switch for a few seconds.
-Open QGroundControl or other uploading based method.
-Flash your firmware. Wait for Pixhawk reboot. Connect to Pixhawk.
-Through QGroundControl, under “System” tab, set all parameters to default. Save. Let Pixhawk reboot if necessary. -Close QGroundControl. Unplug Pixhawk. Plug back in. Let Pixhawk initialize first.
-Open QGroundControl, Set up your preferred vehicle type. Let Pixhawk Reboot
-After it reconnects, go to the radio tab. Pair your receiver and transmitter if necessary. You should be able to receive RC commands now.

***The main fix here is holding the safety switch button down while powering on the Pixhawk. This throws the Pixhawk into bootloader mode. You aren’t necessarily flashing a new bootloader but it has something to do with syncing of firmware versions. Don’t hold me to that. That is my guess. This was the only method that worked to get RC control back. I tried this fix across multiple different Pixhawks with stable/beta/dev/custom_default/custom_lpe firmware.

Usually you are supposed to just format the microSD card to fix these issues but that didn’t work for this specific error. Although to be on the safe side, a good Format to FAT32 couldn’t hurt.

i hope this works for you.

It works!!! Thank you so much!!!

Thank you for your help!!!

I have a Flysky FS-i6S and the solution was to upgrade the firmware to the latest, 2.0.55.

i ve a special problem on my PX4FMU v.7.

After updating firmware via QGroundControl to
px4fmu-v1_default.px4 i got the problem, that my RC-Channels were not recived.

Description on Group-Discussion of this issue are here:

and is described here as well on the manual:

But i do not using the PXIO. So where on the board/ i can find the safety switch or handle this issue?

Your help would be really nice!

Hi, I’ve been having the same problem. I have a pixhawk PRO and futaba Transmitter/receiver. How I could solve this?


Your post is about two months old by now, did you solve the problem?
You didn’t specify which PX4FMU v7 pixhawk you have.
If you have the Holybro Pixhawk 4, the switch is on the GPS module, small long transparent button…
I tried following this procedure, but I am having the same issue, Detected 0 radios… I am using a FrSky R-XSR receiver, maybe I have to try to update the receiver’s firmware…
I tried the 1.8.0-beta2 PX4 firmware as well as the 1.7.3.


Status update: Updating the firmware (LBT) did not help…

I switched to using another receiver… and the FrSky X8R is working fine… Calibration of the radio succeeds. I connected it to the SBUS port of the Pixhawk 4, I still have to check if telemetry is going to the Taranis…

The R-XSR is binding (Green LED is on), but QGroundControl complains about 0 channels detected… I also connected it to the SBUS port of the Pixhawk 4 (FMUv5 Holybro). Blue LED is on, so it is in SBUS mode. I will check if the R-XSR is working with another flight controller to make sure that it is working fine.

I am using the latest 1.8.0 dev build…

Any tips/clues are welcome…

Hello Yuri,

I have also a Pixhawk 4 and trying to configure it didn’t find any radio channel (I’m using same radio with Pixhawk Mini and work perfect). Do you think it is a problem of the new PX4 firmware version?

I still need to do some debugging… Didn’t make time for it yet. Until now I used the X8R which works.
Any tips from pro’s on how to properly debug this?
I’ll try again during next week.


Double check the R-XSR to make sure that the SBUS signal wire is on the SBUS_OUT/CPPM pad (4th from top) and not S.Port or SBUS_IN? And on the Pixhawk, it’s going to the right Pin outs? Please don’t get offended if you’ve already confirmed it. I’ve done this before and swore it was on the right places but after a third look, found it was wrong. I’m just trying to get down to the basics for diagnosis. Hopefully you figure it out and pass it on.

Good luck.

Hi @rollys,

Ok, I’ll check that first.


Hi all I use FrSky Q X7
and receiver X8R with Pixhawk 2.4.8
and I got problem with pairing it with QGrounControl.
I also tried @Sparky002 advice but didn’t help.

I got firmware version 1.8.0

Thanks for any another advice.

Make sure that the polarity of the cable from the X8R SBUS (not SPORT) port is connected properly to the RC IN of the Pixhawk.

Good luck.

Old thread, but for anybody finding this thread in search of wisdom.

Using the standard DSM/SBUS RC to FrSky XSR cable delivered with the Pixhawk4, with a R-XSR receiver you have to move the yellow wire from pin 1 to 2, in the R-XSR side of the cable… (Default connected to SBUS in, pin 1on the R-XSR, shall be connected to SBUS out, pin2)

hello had my x8r working, upgraded a few days ago and i have the same problem once again ,for one i never got my r9 slim or my r9 slim + to detect any channels and now x8r has no channels detected either. i also did what Sparky002 suggested,double checked what Yuri suggested,and what Rollys said with no luck the only reason that i messed with it was because i paid alot of money for uhf set up and i was hoping a later up grade would fix the problem anyway can any one tell me how to use a qx7 Taranis with r9 slim + receiver connected to Qground control with Pixhawk4 fmuv5 ,Who wants to make a video i’ll be your no. 1 fan HELP anyone PLEASE thanks

The R-XSR come with a plug ready to use S.PORT (Smart Port) and not SBUS.

Original S.PORT plug:

Amended plug for SBUS:

You can then connect it to RC-IN on the Pixhawk and it is solved :wink: