Desperately trying to connect to ros2 over wifi

If someone can have ANY tip on where to look, please help me!

I’m trying to make my drone connect to my ROS2 network over wifi using micrortps, but I can’t make it work.

I’m using a PixRacer board, and I managed to connect it over a usb connection doing the following:

  • On the board, I run micrortps_client -d /dev/ttyACM0, then I copy the baudrate, and on my linux computer I run micrortps_agent -b <baudrate>

I’m now trying to do the same over wifi, but I can’t find an explanation of how to do it anywhere. How can I make this happen?

Hi!, have you checked the documentation?
PX4-Devguide/ at master · PX4/PX4-Devguide · GitHub

Not that I’ve used the micrortps_agent/micrortps_client myself but from such document, it says that UDP connection is possible.
And the -i command option allows to specify the IP address of the remote:
-i <ip_address> Select IP address (remote) values: <x.x.x.x>. Default:

I did indeed, but the documentation just says “it is possible over wifi” but I haven’t seen any example. I tried specifying the IP addresses of everything like this and I still have nothing :confused:

I decided to just give up in the end and go back to ROS1 with Mavros. Guess my jump to ROS2 will have to wait.

Once again, I haven’t tried this myself.
If the module is prepared to connect via UDP, it doesn’t matter if the connection is wifi or with wire.
Could it be possible for you to setup a wired link instead of wifi and try again?
Confirming that setup works with (wired) UDP it would be a matter of figuring out what’s wrong or different in moving to the wifi setup.

The wired works fine, I haven’t had any problems with this, strangely enough.

Ok, good. So you’ve confirmed the micro_rtps client/agent works with UDP, as the documentation says.
And now the issue should be to check what’s going on with your wifi connection, from a networking point of view since the micro_rtps component is out the problem.
Good luck!

Yeah I tried everything. Sadly, the answer for me was to get rid of everything and use ROS1 with Mavros.

I don’t have a PixRacer and therefore I never tried this, but looking at the documentation of PixRacer the correct device would be /dev/ttyS0 and not /dev/ACM0. Does that help you?