Custom Firmware HIL issues

Hi guys,

I’ve been trying to implement this change in my PX4’s firmware, , in order to allow attitude commands to be received from offboard mode in HIL simulation. However, when I try to build and upload firmware from Ubuntu console or Qt Creator, the firmware flashes fine but the aircraft doesn’t respond to inputs on XPlane. I can read its telemetry fine, but the control surfaces and motor won’t respond.

Things I’ve tried:

  • Building standard px4fmu-v2_default firmware in Qt Creator and Linux console - the firmware flashes fine but HIL inputs don’t work.

  • Flashing standard stable firmware in QGC - this works and allows HIL inputs to work, but doesn’t fix the original issue of no attitude setpoints in HIL.

  • Flashing beta or developer builds of PX4 firmware in QGC - this also leads to a successful flash but no HIL input response.

I’m on XPlane 10 and QGC daily build, I’ve also tried QGC stable.

Does anyone have any suggestions? I’m only trying to change about 10 lines of code and it’s been bogging me down for weeks!


I’ve been having similar problems on my end (with flightgear as sim) which has held up my finishing testing on that PR (well, that and other projects having higher priority).

Doesn’t help you much on solving the problem…but if I find a fix I’ll let you know.

No solution, but I have narrowed the issue down to something introduced in 1.6.0rc1.

Found it. This is a manifestation of this issue:

Thanks for the thoughts, but would that explain why the QGC stable firmware works but not PX4 firmware built off the Github?

Stable is currently release v1.5.5 (well, a diff between stable and v1.5.5 shows they are identical)