Cube Orange incorrect Current Reading

Hi,
I’ve recently upgraded to a Cube Orange on my multicopter from the Pixhawk4 but I’m having a lot of trouble with getting a current reading out of it.

The power calibration settings/parameters are more or less the same as before, and I’m getting the correct voltage reading out of it, but the current reading seems to have no relationship to the drone’s power draw.
I.e if I do a flight where I ascend and descend, the current does not match the expected motions of the drone.
In the lab, the same thing happens when I artificially induce a load through slowing the motors with my hands whilst they’re spinning (no props on).

I’ve tried changing the bat_I_Channel parameter as others seem to have had issues in the past, but this hasn’t solved it yet.

It’s not that the Amps per Volts aren’t setup correctly, as this would just affect the magnitude of the reading, and not the shape of the graphs in log review.

I’ve tried swapping out the power cable, as well as the power brick module.

Any help would be greatly appreciated!