Crash report quadcopter px4 cube orange

days ago i tried to use my drone manual. I didn’t bring up my pc with drone. I just power on my drone and take off on position mode. I just wanna take off 1 meter from ground and land again. That will be short flight. At the beginning the drone successfully take off 1 meter and i switch on the land mode on controller. The drone didn’t land on the contrary went through back and slowly decrase altitude. I dıdnt give any right, left or thrust. And than when it’s near the ground suddenly pitched to ground and props hit the ground after that totally crash all props and some damages over cube. The drone never take kill switch, land, or fail safe mode actions. The question is what will caused this? why drone dind’t take kill switch? And i have to say that after forget when drone crashed and upsidedown in the ground the propes worked over 10 or 20 sec. didnt stop until i tried to catch their foots. So i approach almost 2 meters while its runnig upsidedown. İt can be about controller signal lost ? if it is why didnt make failsafe ?
The link of flight logs are attached. Sorry about missunderstandings. (

First of all I am sorry for your crash.

I think you didn’t had a gps or didn’t connected it to the cube. Because you never had a 3d fix or gps data and didn’t flew in the position mode. It was altitude mode.
Also you are flying really old version of the firmware, if you don’t have any constraints I would advise you to upgrade it.
And for the problem I think it is more likely that some kind of physical connection problem. Might be that fcu or any of the motor cables got loose, so it created a unplanned pitching moment.

I hope somebody with more experience analyse this further.

really thanks for all your advices. I will do and check all you said. Just one other question why kill switch didn’t worked?

Your RC_MAP_KILL_SW parameter is missing from the logs, so it means it is in default setting in which it is not assigned. That’s why it didn’t work.