Compiling the QGC code issues:

I have installed qt 5.12 to compile the QGC source code but im getting the issue that ":-1: error: Unsupported Windows toolchain, only Visual Studio 2017 64 bit is supported". soo please can you help me with this to compile the code …what should I suppose to do


.

Hi, did you find a solution for this problem? I am facing the same issue

yes ,i tried to download visual studio code while installing in qt soo it worked. But now I’m facing compiler issue.Are you working on same project?

Oh, but in my system visual studio is already installed, so should i reinstall it?
Yes, I am working on same project
Since, I wasnt able to do it, i switched linux system.

theses are steps I followed to debug i.e. you can check with all the requirement.

  1. Install Visual Studio 2017 64-bit: Download and install Visual Studio 2017 Community Edition or a higher edition that supports 64-bit compilation. Make sure you select the necessary components during installation, including the C++ development tools.
  2. Configure Qt Creator: Once you have Visual Studio 2017 installed, you need to configure your Qt Creator to use the correct toolchain. Open Qt Creator, go to “Tools” > “Options” > “Kits”. Select the appropriate Kit that you want to use (likely a 64-bit version) and make sure it’s associated with the Visual Studio 2017 compiler.
  3. Clean Build: After making these changes, try cleaning your QGC project and rebuilding it. Sometimes, issues can arise from old build artifacts or incorrect settings.
  4. Check QGC Documentation: Make sure you are following the QGC build instructions provided in their official documentation. The documentation may include specific steps or considerations for setting up the build environment on Windows.
  5. QGC Community: If you continue to encounter issues, it’s a good idea to seek help from the QGC community forums or GitHub repository. Other developers who are familiar with the QGC build process might be able to provide specific guidance or troubleshooting steps.

I’m happy to hear that we are working on same project.

Hi, is it necessary to download the visual studio 2017 version or 2022 is fine because i am not specifically getting the download option for 2017 version

no, u need to install Visual studio community 2019.ill share the link from that u can download but u need to sign in in Microsoft acct to download the older version.after u sign up u can go to visual studio community 2019 84 bit u can download.they have some time limit just check with that.
link -“Azure DevOps Services | Sign In

I just successfully build the desktop version using Visual Studio 2019 as mentioned in the docs and then installed Qt.

Note: The Desktop version build on Windows appears to be working fine.
However, I also build a Linux Desktop version on a Linux system (KUbuntu 22.04) whilst it appears to work at first glance it will not accept any input in the Application Settings page. - Crashes instantly when clicking on any line other than the drop-down options.