Companion computer problem

Hello!

I want to use offboard control, I do not have an odroid or raspberry boards, I am using a ubuntu pc with a long usb cable and I want run the mavros offboard control example code (https://dev.px4.io/en/ros/mavros_offboard.html).

So, I have enable the companion computer interface (SYS_COMPANION TELEM2 to 921600 baudrate).

I am reading this tutorial: http://ardupilot.org/dev/docs/odroid-via-mavlink.html and I am using a USB to Serial interface.

I have a db9 connector and I am connecting Tx , Dx and ground to telem2 pixhawk.

When I run “rosrun mavros mavros_node _fcu_url:=/dev/ttyUSB0:921600”, I can’t start mavros.

What is the problem?

Maybe is my db9?

Do I have to use another interfaces serial ?

Thanks!

Are you using a USB to TTL or USB to RS232?

I am using USB to rs232

RS232 has different voltage levels (-15V to 15V), connecting RX and TX from RS232 to the UART on a pixhawk is likely to damage it, you need to use a USB to UART TTL level, best 3.3V.
Compatible USB sdapters are shown in the manual that you are referring to.
Rx line from the adapter goes to a Tx pin on the pixhawk,
Tx line fom the adapter goes to an Rx pin on the pixhawk

Hello!

I solved the problem, I used USB to UART TTL (xbee usb adapter with 921600 baudrate) and it worked.

Now I can run mavros.

thank you very much! @gregswf

No problem, good luck.

Hello! @gregswf
I have a question

When I connect my companion computer to pixawk, I can run mavros but I can’t run QGC.

Is it normal that I can not run QGC?

Regards and thanks!

You can not run QGC at all or it runs but does not connect?

I am running QGC in my Ubuntu pc (companion computer)

Does QGC start but it does not connect?

Yes I can run QGC it no connect, maybe I have to check autoconnect options for devices

I think normaly QGC connects to a pixhawk via USB and 115200 baud rate.

You are connected to your Xbee at 921600 baud rate

What if you go to comm links and add a new connection to /dev/ttyUSB0 at 921600?

I’m not sure if you can have your mavros installation and QGC connected to the same port at the same time eather.

When I connect to QGC I am not using mavros, I have never connected to QGC and mavros at the same time

Now I’m getting this message

Is this aftwr adding a new connection?

I have added a new connection but I get the same message

Try different baud rate?
115200?

If you are using a computer, then it is very common to face some errors like connectivity error, driver error etc. So, I will suggest you visit epson printer error code 0xf3 to get the required actions to be taken to make the errors solved.