Connect pixhawk via cable

#1

Hello :slight_smile:
I have always been connected to my pixhawk via telemetry, now I want to try my set-up via cable. When I change my fcu_url:=/dev/ttyACM0:57600 or fcu_url:=serial:///dev/ttyACM0:57600 in the terminal the messages stop at MAVROS started. My ID 1.2400.
Do you have an idea what might be the problem in connecting to the pixhawk via cable. I checked I have the device in /dev or should I connect it to the QGroundcontrol and then connect to it as udp. What should I do?

1 Like
#3

Hello, I think your baud rate is wrong. PX4 runs the usb interface at 2Mb/s. Try with the following url:
<arg name="fcu_url" default="/dev/ttyACM0:2000000"/>

#4

Moreover usb is not recommended for flying. If you need higher baud rates you can use TELEM2 and increase the baud rate to 1.5Mb/s.

Previous to firmware version 1.8.1 -> set parameter SYS_COMPANION to 1500000
Firmware version 1.8.1 and later -> set parameter MAV_1_CONFIG to 102 and after reboot set SER_TEL2_BAUD to 1500000