Cannot see almost all VTOL Attitude Control Params in QGC


I’m still very new to PX4 and Qgroundcontrol so apologies if this is very trivial. I’m currently building a 12 motor Dodecarotor cox Drone (Hex orientation) and currently I’m having an issue trying to enable one of the VTOL atittude params. Specifically, I’m trying to enable the VT_MC_ON_FMU param (found here which enables the use of the AUX outputs for hover motors (currently all my motors plugged into the AUX ports aren’t spinning). However, in Qgroundcontrol, When I filter for VTOL Attitude Control Params (i.e. VT params) only two VT params appear as shown below:

Currently here is my Hardware/Software:

  • Pixhawk Cube Black
  • Firmware Version 1.11.3
  • Airframe Type: dodecarotor cox
  • All other calibration steps are complete (green lights for all sections)
  • QGC Version: Development HEAD: 78cf9bbe6 2021-05-06 10:49:59 -0700

Any help to find these other params would be greatly appreciated, Thnx!

I’m not sure if this is your answer but try loading the Dev version firmware. By the way, I took the liberty of changing the category to VTOL. Hopefully, more can chime in.

Good luck.

Hey Rollys,

Thanks for the advice (and changing the category :slight_smile: ). I also have a pixhawk pro 2.4.8 and tried to see if I could see VTOL attitude params on another piece of hardware and couldn’t (by also flashing the hardware with the Dev firmware). I even followed this guide to do the FMU v2 bootloader update on FMU v2 boards (Loading Firmware | PX4 User Guide) and still couldnt see the remaining params (the FW version was 1.12.0beta). Any other ideas? Thanks in advance.

Also general question: does doing the vehicle setup (i.e. sensor calibration, radio setup etc.) reveal more params as you go, or should all available params be visible immediately after flashing FW.

Hi, You need to select VTOL Airframes for more parameter of VTOL.