Cannot enable MAV_{i}_BROADCAST

I updated pixhawk firmware to the latest version. To the purpose of my project I use Gazebo for simulating fixed wing plane and I need to have MAV_BROADCAST parameters enabled for receiving and sending messages from another MAVLink interface on Windows. I use PX4 version v1.12.0-beta5-45-ge498023d0f.

I have set MAV_BROADCAST for all instances in the simulation to the 1 value. Value is set, but every build ends in information that it is not enabled. This option is not also visible in QGroundControl in parameters view.

I set param value via command:
param set MAV_0_BROADCAST 1

Info during building firmware:
INFO [mavlink] MAVLink only on localhost (set param MAV_{i}_BROADCAST = 1 to enable network)

How can I enable it?

1 Like

I have managed with this problem. Here is my solution:

  1. Find the file px4-rc.mavlink located in /etc/init.d-posix in pixhawk build.
  2. To the mavlink instance start command append parameter -p to enable broadcasting.
    mavlink start -x -u $udp_gcs_port_local -r 4000000 -f -p
2 Likes

brilliant, thanks!

This let me run gazebo in WSL2 in Windows and connect to QGroundControl.