Airplane does not takeoff in HIL using QGroundControl and X-plane

#1

Hi all,

I am trying HIL simulation with QGroundControl 2.9.6 and X-plane 10 demo. I followed the steps here: https://pixhawk.org/users/hil
and used the HILStar model.

All the connections and setup seems just fine. However, when I arm under the mission mode after I set a few waypoints, the airplane just sticks to the ground and does not move, although the QGC shows that the throttle is up to 100%. I also tried manual control using joystick and the problem is just the same.

#2

QGC 2.9.6? Wow, that’ old! First step, use an up to date build.

#3

Yep I tried the latest QGC build and flashed my pixhawk firmware and the problem is still there :frowning:
Although it seems that xplane and QGC communicates well, I suspect that the throttle command is not actually passed to the airplane. Or perhaps something else is wrong.

#4

Maybe some sort of xplane setup problem? We have other folks using xplane and qgc without problem.

#5

What might it be? I followed the instruction exactly.
Does it have anything to do with the demo version I am using?

#6

Can you display the throttle data in X-Plane to see if it is receiving the same data that QGC is sending? Is it just the throttle that doesn’t work or can you not move rudder, ailerons etc either? I have only ever used X-Plane 11 for HIL, but I have used it in the demo version and it was fine.

#7

That is exactly the problem: the throttle in X-Plane is 0. I don’t think I can move the rudder or ailerons either.
Perhaps I should try X-Plane 11. I didn’t know this version of X-Plane is also supported.

#8

Strange! In the HIL config widget GUI (at least with newer versions of QGC) there are two checkboxes - “enable sensor level HIL” and "use newer actuator format - are both of those selected? If not that could be the issue. Also, are you using XPlane and QGC both on the same computer? I found this works more reliably than when I had them on separate computers.

Is QGC getting data back from X-Plane? Can you see the airport location from XPlane in QGC?

#9

Yes both the checkboxes are selected. QGC is getting data from X-Plane like the airport location and other variables.
I am running things on the same computer. How do you setup on separate computers? Do you just change the ip addresses to the actual ips of those computers?

#10

Yep, all you have to do is change the IPs, the port numbers stay the same.

In manual mode, are you able to arm the plane using the RC transmitter? I’ve never tried using a joystick.

#11

hello .i want to know have you solve the question ,and how to solve it ,thank you very much.

#12

Looks like it was a firmware problem. I got things running with version 1.5.5 (which is a really old version) and any later versions do not work with it.

1 Like
#13

hello ,this problem perplex me long time .I have programme the version 1.5.5 to pixhawk ,but I can’t change the airframe of the board.Can you help me ,please!!!

#14

hi, where did you get the firmware?