Can not use HOLD or MISSION mode using HIL with X-plane

#1

Hello everyone. I just started with the HIL simulation with X-plane and qground control but I have some trouble. I could make the connection between qground control and X-plane and tried STABILIZED and MANUAL mode but when trying to switch to HOLD mode, I get a message saying that is rejecting that mode. I do not know if this problem is related to the missing airspeed sensor or something else. Does anyone know something that could help me?
Best regards
Andres.

1 Like
#2

I will be doing something similar very soon. I’ll see if I will run into the same problem.

Perhaps we should stay in touch and share notes. :slight_smile:

#3

Hello Safat, I finally made it work a couple of days ago. I realized that the GPS was not fixed when I tried to enter to HOLD or MISSION so the flight mode was rejected. For any reason, when the computer (where the simulation is running) is making some other complex tasks, GPS starts failing but, when just X-plane and QGC are running, GPS works good enough.

#4

I’m stuck in the very first stages because my controller isn’t being recognised by QGC. There are some driver issues going on. Despite me installing all the necessary drivers while installing QGC, it says “No drivers installed” in my Windows 7 Device Manager. Trying to fix that now.