[change mode]Hold, Auto

#1

HI,

I can’t change flight mode, I’m always stuck with rejected flight mode answer from QGC, does any body facing the same problem, I can change only to stabalize, manual, acro, ratitude, and attitude.
Please help.

Best regards

#2

Hello,
Auto flight mode is rejected e.g. if there is no flight plan uploaded. I guess flight modes requiring GPS lock are rejected if that condition is still not acquired.

#3

HI,

Thanks for your answer.

Do you mean that there is no possible way to hover the drone at the current position if there is no plane uploaded? there is Auto hold flight mode, and Auto mission flight mode, it make sense for mission flight mode. but what about AUTO HOLD???
I can’t access any mode that hover the drone in the current position !!
The only mode I cant change in between are STABILIZE, MANUAL, ACRO, RATTITUDE, otherwise all others are rejected.

Please help.

Best regards.

#4

Hi,
not plane, flight plan. You can’t start an auto mission if there is no mission planned, Auto mode is then rejected.
Hold requires a GPS lock, otherwise the controller does not know where to hold. Are you sure you have a GPS lock?
Best regards,
Ric

#5

HI,

I don’t have a GPS installed on the pixhawk, and I don’t want to, I want to find a way to achieve altitude hold, or loiter without gps, because my drone is intended to fly in indoor environment.
Also, I’m using a quadcopter, with x configuration, and px4 firmware last version.

Best regards

#6

If you set option Arm Without GPS (which I guess is default), you should be able to have a barometric altitude hold, but no position lock unless you implement some other hardware like optical flow etc. I have around hardware for that, but still not tried. I flew in altitude hold mode and had good experiences. As it seems to be some race orientation on PX4 I guess altitude hold will work without GPS, but I would like a confirmation from a coder here.
Did you try flight mode Altitude Control?

#7

To be perfectly honest with you if your not going to have a gps you should go with a $25 or cheaper flight controller.

What you are able to do is use the barometer for altitude. The compass may be of some use. Other than that you need gps. The flip32 pro has this capability.

#8

i think beyond barometer there are others like flow or Lidar can make copter hover indoor without GPS. That may not working with Auto mission if lack of some external aid out of the box, but feasible.

#9

Those are alternatives to baro which also allows the fc to control the altitude.

Basically without gps your going to be on the stick all the time. All those modes that are denied require positioning.

There are some using lidar to map walls etc.

http://digital-library.theiet.org/content/journals/10.1049/iet-rsn.2016.0232

Maybe look at the arducopter camera based solution for now.

#10

As you said i have Arm Without GPS set by default, also i have optical flow connected to the pixhawk,
and well calibrated. However even with those two I’m stuck with STABILIZE, ACRO, MANUAL, RATTITUTDE. all others are rejected, even Altitude control.

I really want to understand why it is always rejected, I would like also from developers to point to us the place in the firmware code, where the px4 change the flight mode.

#11

I’m happy with Pixhawk for several reason, first it’s open source, then it started to have well developed community of users, if you tried other drones like parrot, you will see that by default even in indoor environment the drone by default hover in the same altitude without GPS.

If this is possible with Bebop drone of parrot, there should be no reason that it doesn’t work with Pixhawk.

#12

AUTO XXX modes are GPS only. If no GPS, you will be be able to use those.

If you are going to do indoor flights, you can have the easy “position control” if you have a position feedback : PX4Flow, Mocap, Vicon, GPS, Decawave (UWB), Ultrasound (another don’t remember the name). For the 2 last, you need an onboard computer.

Orelse you can use the ALTITUDE mode if you connected a position system or a laser.

For autonomous flights, you will probably use OFFBOARD mode, which also needs a position feedback.

#13

Hi,

Thanks for your answer.

By following your proposal, I should be able to use Altitude control mode ALTCTL, and position control mode POSCTL, as I have optical flow camera connected to the drone with no GPS connected to the drone.
However until now I’m only stuck with MANUAL XXX mode.
I would like to know how to be sure that the drone is using the optical flow camera. is there any configuration to do?? the only think i have done for the camera is that i have connected it to QGC and
optimized the focal lens as have been described in the documentation.

Best regards.

#14

@shrit
Hey, new user here. Your problem seems quite close to mine. I’ve tried messing around with the parameters, but it seems like no matter what I do, I can’t get it to leave Manual or Stabilized mode.

Did you ever get this to work?

Cheers!

#15

Hey,

I were able to pass to altitude hold, (i have optical flow that seems to be not working) otherwise for other
mode you have to have GPS, or some kind o localization system

#16

Oh alright. I’ve got a PX4Flow sensor + TeraRanger, so I’m hoping that it should be enough for altitude and position.

Do you remember what did to get Altitude Hold working?

Thanks for the quick response, by the way!

#17

just switch to it, but for position control, it doesn’t work with me

#18

Whenever I attempt to run it, I get the message “FCU: REJECT ALTITUDE CONTROL”.

If you didn’t have this problem, I’ll keep looking for a solution. Thanks for your help though!

#19

I have QGC-Station and fly-mission-plan, when i set up all the points and I load the mission, I get the error ‘Unable to start mission (‘vehicle not ready’)’.

In other words,

I have tried position control and the drone responded quite satisfactorily using the RC transmitter. However, when I want to try fly mission mode, I can see that the GPS position is jumping even though the QGC takes up till 9 satellites, and the GPS is locked and the HDOP < 1.5 and the VDOP < 1.5.

I can chose the way points and load the program but when I want to change to mission and arm I get the error: I get the error ‘Unable to start mission (‘vehicle not ready’)’.

Do you have a clue about this :slight_smile:

Thank you and looking forward to your replay

#20

@kholdcro did you manage to get this to work?