Can i stop motor spinning when arm

#1

Hi,

I would like to disable the motor spinning when arm. how do i do it?
For APM stack, it use MOT_SPIN_ARMED. how about on PX4 stack?

Thank you

YAW is not responding on QUADROTOR X
#2

You could reduce PWM_MIN parameter until the motors stop spinning.
Not sure what your goal is though.

#3

We’re generally don’t support this. If you don’t want to spin the motors then don’t arm.

#4

okie. thank you :slightly_smiling:

#5

My motors don’t spin when armed… Small 250 quad.
What parameter should I look at so that they do spin?

#6

Check for the PWM_MIN parameter and make sure it’s high enough.

#7

Hi,
by setting PWM_MIN to 1000 the motors don’t spin when the throttle is down, for them to spin even when throttle is down PWM_MIN should be higher (but not too much in order for the vehicle not to take off even when you arm the system). The default value for PWM_MIN in multicopter mode is 1075.

#9

You could try programming a kill-switch onto your RC controller. The option is available in QGC.

I use a kill-switch for safety reasons when testing autonomous flight modes. I’ve noticed that sometimes following deassertion of kill, the multicopter behaves strangely if it is in any mode other than manual.

If you choose to use a kill-switch, I recommend you switch your vehicle control mode to manual before deasserting kill.

#10

Hello, I cannt stop motors spining even if I set PWM_MIN to 1000 or lower , can you give me some advices?

By the way, My channel 3 output PWM does not equal moters PWM, does this influence the problem? I have calibrated ESC without Pixhawk successfully. But with Pixhawk and QGC, it always say “Timeout waiting for bat”. Any way to solve it?

Nice Weekend!

yun

#11

@yun it seems like your power monitoring system is not working. Is it showing you any voltage when you connect to QGC and have the battery connected?

#12

heellooo. none solution…???

:@ i am have piwhawnk 2.3.8 (clone)… working good…
need motors stop on armed… an run stick up !.

#13

You can adjust PWM_MIN to a value that won’t make the motors spin.