Pixhawk quad motors spinup after arming

i am a newbie to pixhawk and using ground control software ,so my questions my seem very basic to this group, hopes that not problem,
just setup a pixhawk 2.4 FC on a DIY s500 frame, with px4 firmware so far all seems fine , but the issue i am having is the motors start spinning after arming , can this be changed so they don’t spin until throttle is raised.

thanks tony

Hello Tony

Have-you connected the ESC on PWM Out Ports (according the frame chosen)?

The props spin on purpose after arming and there are at least two reasons for it:

  1. Control performance: The ESCs/motors need some time from 0 to spinning, therefore for a fast control response you never want to be in the 0 range but only operate from an idle (spinning) throttle and upwards.
  2. Safety: When the motors spin it’s a clear signal to anyone that this drone is armed and should not be approached.

If you really don’t want that, you can reduce the minimum PWM setting with these params: