Binding Spektrum Satellite (DSM2) in QGC radio setup

Hi all,

I am trying to set up my Pixracer for the first time on a Spedix S250 quad with the included DSM2 satellite receiver. I have flown the model using the CC3D board that was included with the Spedix kit and it worked fine. However, now that I am trying to set up the radio in QGC, I am unsure how to get the transmitter (I am using a DX6) to bind with the receiver to set up the radio for the Pixracer.

I have tried clicking Spektrum Bind and then selecting DSM2 on the window that pops up in QGC, but nothing happens. Do I need to have a battery plugged in to bind? I think that the satellite is in bind mode, because whenever I powered up with the CC3D board, the satellite would flash rapidly, I would power up the DX6, hold the Bind button, and they would bind.

This is my first real quad and I am a total newbie to this, so I probably am not understanding something pretty simple.

Thank you for the help

When I plug in a battery and the pixracer is not connected to the computer, the satellite does not light up, but the ESCs and the pixracer do.

I hooked up the CC3D board again to see if the receiver just wasn’t working, and it would light up and try to bind with my transmitter, but the binds failed every time. I don’t think that the receiver is bad though.

Does anyone know whether using ArduCopter and Mission Planner would be a better option for Spektrum?

Hi Ezra,

Could you verify the version of QGroundControl and PX4 firmware you’re using? Spektrum bind support was recently improved. As a temporary workaround If you have a regular receiver you can use it to bind the satellite and then reconnect it to the autopilot.

I am using QGC v3.0.2. I downloaded it today and flashed the Pixracer with PX4 today. I’m not sure how to find the version of PX4 that is on the board.

I do not have a separate receiver.

The firmware version will show in the Setup / Vehicle Summary page.

It says version 1.4.4dev.

You need to flash master / development version.

I just tried to do a firmware upgrade in QGC but I still have 1.4.4dev. How would I flash the master/development version?

@ezra that’s an error in the stable reported version. When flashing through QGC select advanced and development for master.

Ok thanks, I’ll try that.

Now I have 1.5.0dev. QGC gave me a message that it supports versions 1.4.1 and following, but that this version is prior to 1.4.1 and may lead to unpredictable results. Is it saying this just because 1.5.0dev is a developer version?

Also, is it possible to bind a Spektrum satellite receiver to my transmitter using the Pixracer? I read that I will need a normal receiver as well.

I just tried it with just a satellite and it’s working, thanks guys.

The fact that QGC is complaining about 1.5.0 dev is likely a bug in the firmware. It isn’t reporting the firmware version correctly.

Ezra - I am curious how you got this to work? I have a Pixracer and Spektrum AR6210 + satellite. Cannot get the receiver to be recognized by QGroundControl.

I have actually stopped using the Pixracer/PX4 platform and it’s been a little while, but I think that I got the receiver to get recognized by downloading the developer version of the PX4 firmware on the Pixracer. I think that when you go to reload firmware you have to open the advanced features or something like that to find the option to load the developer version. I hope that helps. Also, I was actually just using a satellite, so if you are using the full receiver plus the satellite, I am not sure how/if that would be different.