QGC Detected 0 channel of Spectrum DSMX receiver

Hi Guys,
Commnunication between pixhawk 4 and STC4651T DSMX receiver using QGC, does not work.
my setup consist of

  • pixhawk 4 (uploaded newest FW via QGC)
  • SPM4651T DSMX sprectrum receiver
  • DX6e Transmitter

please see setup drawing

When performing “spektrum bind” from QGC this make Pixhawk led B/E blinks yellew for ever, but nothing happens. Futhermore it is not possible to “Calibrate” Radio Setup, keeps getting
"Detected 0 radio channels. To operatate PX4, you need at least t channels".
When I try to bind from transmitter it seem to be working.
Pixhawk documentation state that all spectrum DSM pairs is supported. I spend a lot of money on the kit Pixhawk 4 and receiver/transmitter setup hoping it was plug and play. What seem to be problem here? please help me on this.
br

Do you have a possibility to perform the binding process without the Pixhawk?
There is also a parameter SYS_USE_IO = 0 to bypass the I/O unit for further troubleshooting.

Thanks taileron for the answer.
Yes I can bind the from the transmitter, and it is displayed on the transmitter screen that it is binded. Regarding the SYS_USE_IO parameter, do I need to set it to 0? Can that be done in QGC?

Can be set by QGC (vehicle parameters)
set to 0 means the pwm outs and the receiver are directly managed from fmu.

So I tried to set parameter SYS_USE_IO = 0, rebooted and doubled check that is set. What do I expect from this? it still reports “Detected 0 radio channels. To operatate PX4, you need at least 5 channels”.

What is the next step taileron?

This has excluded that there is a hardware or software issue with the IO unit. Now there can only be an error in the connection itself. e.g. an inversion at the sBus connector.
If the controller cannot switch off this inversion, Spektrum will not be detected at this connection. Isn’t there a dedicated connector for Spekrum receivers? Attention SPM 4651T doesn´t work with 3.3V which comes from the Spektrum connector. Probably voltage 5V (red) to sBus port and receiver the other colours have be connected to the Spektrum port.

Thank you for pointing out that receiver needs 5v supply. I found a dedecated cable for that and tried again but still the same result. An inversion, how can i know if that is the problem? Is there a detailed debug log of the communication you can access from pc?. Are you sure its not a firmware issue? I read other threads where the fix is mess around with bootloader see link below. (But i dont have a safety switch) other state it is current firmware bug) what do you think? Or could it simple be that this receiver is not tested with px4 og perhaps therefore is not supported eventhrough it is stated in doc.

Pressing the safety button while boot forces an update to the IO unit.
(like mavlink console: px4io forceupdate command)
With some fc the current master doesn´t see the dsm(x). with SYS_USE_IO = 0 enables rc in this case if there is no issue about inversion. If everything is connected correctly and the voltages are correct it should work up to V1.10 there this issue did not occur with me yet. You can try to type dmesg into the mavlink console for more detailed boot information.