Avionics power low

Hello.

I just finished building my 600mm quadcopter, using the new Pixhawk.

When arming, I get the following error:

Avionics power low: 4.3Volt
Preflight checks fail.

What is causing this? I am connected with a 433mhz telemetry radio.

Also, I cannot get Qgrouncontrol to display the voltage or battery status.
I am using a 5 in 1 Damping Plate, with voltage sensor.


Thanks! :slight_smile:

Bump!

No one knows this?

Had this problem for a week now. No solution yet.

I might go buy a Naza system… :frowning:

same problem here
it seems to be 1.6.5 version problem
I went back to 1.5.5 and it fixed

1 Like

Thanks! This worked :slight_smile:

This message means that the 5V supply to the Pixhawk is dropping below a certain threshold. This can be dangerous as it can lead to inconsistent behavior of the flight controller itself or components powered by it (e.g. GPS). Rather than switching to an older version that perhaps checks this less strictly, I would recommend checking the voltage (e.g. at the power input port of the flight controller, the GPS port, I2C ports, etc) with a multimeter to ensure its stably around 5V. If you think it is and the reporting is therefore false, I’d open an issue on Github.

thank you Nicolas
you’re right it was not a version issue it was pixhawk hardware issue (from alibaba :angry:)

I tested with multimeter and voltage was around 4.5V
while my old pixhawk from 3DR outputs 4.97V and works fine with v1.6.5

and this low avoinics voltage output problem causes all kinds of problems in flight performance which I was struggling for week

thank you for your help

I get 4.9V on the pixhawk and sensors, and about 1A output. Very strange that 0.1±% has an effect on the system. Any suggestions fixing the problem? After downgrade, I still get the Avionics power low, but the software bypasses it. Strange

Two things.

First, The Pixhawk depends upon voltage/current translation from the power module, using a scaling which can vary (normally) over temperature and the specifics of your hardware.

Before you give up, measure your battery voltage by hand (preferably at the terminals leading into the power module, while the battery is connected), and then make sure the “voltage divider” setting in Power Setup (QSG) is correct: press [Calculate], plug in the value you measured, and then press [Calculate] again.

Second, I’ve noticed PX4 getting increasingly fussy about having a solid 5.3VDC+ supply at the power port of the FMU itself. This is IMPORTANT, because if you feed it just the typical 5VDC from a BEC that isn’t APM/PX4-aware, then the onboard regulators are in dropout. This is a bad situation to fly in.

When Pixhawk’s regulators are in dropout, ALL your downstream devices (anything powered from a Pixhawk port) get an unstable supply level—making them unpredictably (but predictably) VERY unhappy.

Unfortunately, all Pixhawk-clone hardware really NEEDS a 5.3VDC+ source supply, as far as I can tell. And since so many PDB/BEC combinations use switching buck regulators, they aren’t easily adjusted upwards from their 5VDC factory setting.

I’ve given up using anything but true, APM/PX4-aware power modules for just this reason. It sucks, because there aren’t many PDB/BEC-style ones available. And the newer, Hall-Effect ones are physically, inconveniently large.

If you’re using a 5V BEC as your upstream power supply, then 0.1% variability is because the regulators onboard the Pixhawk aren’t actually regulating: they’re in dropout.

Boosting your upstream supply above 5.3VDC is the only stable solution, unless your setup lets you power your downstream devices independently.

I have a rather large hexacopter. Pixhawk 2.4.8 PX4, powered from a power module GM v1.0 which gives me a constand 5.2V when measured. Everything seems fine until the warning

Avionics power low 4.8 (or 4.71 or such)

keeps showing up. I have switched the module and batteries and the same error keeps occuring. When I ignore the warning and arm it, the props will rotate but very slowly at low power.

Any Idea what my problem could be?

I also have this problem on my pixhawk px4. Same. I measure around 5.2V input, but the log file sais something different. Namely around 4.8V

The pixracer I power from the 4in1 XRotor 40A
The pixhawk4 from a powermodul.

Any Idea what my error is?

https://logs.px4.io/plot_app?log=8c0e9893-1994-4cfd-b1b3-f884fc9e9b5a
https://logs.px4.io/plot_app?log=8c0e9893-1994-4cfd-b1b3-f884fc9e9b5a
(btw. parts of the quads are dissasembled, therefore if mag is off that makes sense)

Hi @marvin.
If the voltage is between 4.5 and 4.9 you ‘only’ get a warning. It will still work, but nevertheless should be looked into.
Which power module are you using with the Pixhawk 4? The officially supplied one? What else did you attach?
For the Pixracer I think we also use that combination, but I haven’t noticed any issues. Since it’s right at the limit and generally looks stable, you can set the circuit breaker to disable the warning via CBRK_SUPPLY_CHK parameter.

Hi @bkueng

Thanks a lot for the answer. So these first two quads are only meant to be quick prototypes. So I am playing around with cheap hardware. The modules are from Readytosky from china. (called Pixhawk PX4 PIX 2.4.8 32 Bit Flight Controller, and pixracer). I am not sure if those are officially supplied… but probably not.

For the pixracer I tried all combinations from almost nothing to connecting a sik radio, mini osd, X4R FrSky and gps (which if all were connected caused the memory to overflow when calibrating). The aviation power low warning was consistent.
Similar for the Pixhawk. There I can connect two gps and a sik radio and no memory issues. However the aviation power low warning persists, event though I measure a good input voltage.
The power module I am using is a standard G M v1.0 http://ardupilot.org/copter/docs/common-3dr-power-module.html also from china. I tried two different ones.

Where does the chip measure the input voltage? On the pixracer the two middle wires of the powerport are not connected.

Thanks for the input with the warning. However, my goal is to build a larger, stable filming drone that is redundant and safe (with better hardware later on). Is it still safe running on the low voltages (or presumably low voltages)?

You find the pinout here: https://docs.px4.io/en/flight_controller/pixracer.html. The 2 middle wires are for battery voltage and current sensing. I don’t know where the 5V is measured internally.
If you want to build a larger and reliable drone, I suggest you use high-quality and officially supported components, even for prototyping.

Thank you @bkueng. The problem has solved itself when powering the pixhawk through the motor 8 power and ground pwm port.

Yes. Given that I have not been in drones for 7 years I am not up to date. How do I tell what is officially suported? And what is not? Given most parts are from china I have a hard time.

Generally by using the links we have in our documentation. But you’re right, it’s sometimes impossible to tell, and usually other parts work as well.