2 Axis Gimbal Cnfiguration

Hii all…

I’m trying to configure the 2 axis brush less gimbal to control with the mavlink.
When i powered the gimbal it’s it’s moving. I connected the Go Pro to the gimbal and tried to control with the RC but I’m not able to control the Gimbal.
Later i get to know I need to configure some settings for the Gimbal by using the Simple BGC GUI. I installed the GUI and when i trying to connect with the GUI to Gimbal It’s not connecting and showing the Error Firmware Version and GUI Version is not matched. I tried to upload the 2.4 version firmware into the Gimbal controller board by using X loader software but it’s showing that uploading is failed.

If anyone have solution for this problem please let me know the steps how to solve this error…

Thank You…

What gimbal is that?

Hii @JulianOes

I’m using Light weight brush less 2 axis gimabal

Ok, with what software? Or what interface does it expose? Does it support MAVLink?

Hii @JulianOes

I’m using Lightweight 2 AXIS Brash less gimbal…
Link: https://robu.in/product/lightweight-2-axis-brushless-gimbal/
I’m using Simple BGC GUI to configure the gimbal and I connected to gimbal to through Micro USB.
Regarding whenever I’m trying to connect with Gimbal to the GUI the older version GUI’s automatically closing when i click on connect button.

When I used the latest version GUI Previously It’s showing GUI Version and Firmware Version is not matching and i uploaded the 2.0 Version firmware the i’m trying to connect with the GUI it’s showing connecting…

So it has something like PWM input? In that case you would have to set the MNT_MODE_OUT param to PWM output.