Xbee s2c + px4 on Pixhawk 4

Hi,
I’m trying to use 2 xbee (one router, one coordinator) to make quad communicate with any gcs.
While xbee’s are connected to pc and working on XCTU, 2 Xbee’s communicating with each other without any problem but when i plug the coordinator one to pixhawk’s telem1 port and try to connect with QGroundControl or mission Planner there is no heartbeat.
And when i plug the coordinator onboard, over router on XCTU - network mode i read some packages transmitting and receiving and i can manage coordinator Xbee’s params.
For addition i use raspberry pi on telem2 port and i connect without any problem.
My hardwares and softwares:
pixhawk 4 — px4 latest stabile firmware
xbees : XBee PRO S2C XBP24CZ7SIT-004 — DIGIMESH 2.4 TH PRO (9002)
other avaliables firmwares : ZIGBEE TH PRO, 802.15.4 TH PRO
Others: baud rates tried on 57600, 921600, 115200 as px4 serials, xbees and gcs have same value
mav_0_config enabled and mav_1_config disabled tried
mav_0 _config disabled and mav_1_config enabled tried
mav_0_config and mav_1_config tried both enable on telem1
mav_0_mode -> normal
mav_0_rate -> 1200 B/s

waiting for your responses…

İyi günler aynı problemle ben de karşılaştım acaba çözüm buldunuz mu?
I have a same problem.have you ever solve