Xbee not working with cube orange

I am using Xbee pro s3b module. If 2 Xbee’s are connected to computer , the communication is happening in XCTU. But If I connect one of the Xbee to cube orange telem 2 port, it is not transmitting any data.

I have tried different modes (transparent / API), different buad rate (57600,9600), giving telem delay (10s) from mission planner, different protocol (MAVlink1/ 2). Xbee is still not transmitting.

Configurations used:
Xbee 1 - coordinator (CE=1) - connected to PC - XCTU
Xbee 2 - Router (CE=0) to cube orange telem 2 port (only connected VCC, Gnd, Tx, Rx) - didn’t connect CTS and RTS pins. Also disabled them in mission planner BRD_Ser2_RTSCTS config. In Xbee’s also disabled CTS and RTS I/O
Buad rate: 57600
AP = 0 (transparent mode)
ID = 2222 (same for both Xbee)

Mission planner (cube orange settings):
BRD_Ser2_RTSCTS disabled
Serial 2 buad rate = 57600
Serial 2 protocol = MAVlink2

Please let me know if anything else can be changed for Xbee transmission

If the Xbee’s are in API mode, in XCTU networking working mode, I can verify that both Xbee’s are connected. I suspect the issue could be the cube orange telem port not communicating with connected Xbee.