Why yaw is moving slowly ccw in position control?

#1

As seen in the plot, yaw set point is moving slowly in ccw direction while flying in position control mode.


https://logs.px4.io/plot_app?log=46ddb52d-9e82-4e86-bacc-257c7e29f666

Also plotted with my rc input and there is yaw command is not moving.

I noticed the magnetic field around the area is not so good but it does not explain setpoint is moving.
Even if the magnetic sensor is off by certain amount, setpoint should maintain it’s initial setpoint.
Is this intentional behavior?
Can anyone experienced this issue before?

Kyu

1 Like
#2

could you share the .BIN log ? - that service gives me something called “ulog”, which I can’t use.

#3

Hi @Kyuhyong_You ,

The RC yaw input has a slight offset:


You need to re-calibrate your RC transmitter.

As a proof, you can see that during t =~ [0:35 0:36], the RC signal is at zero and the yaw setpoint stops moving:


@AndKe ULog is the official log format supported by PX4, you can open them using those tools.

1 Like
#4

Hi @bresch
Oh I didn’t notice that. Should test again tomorrow. Thanks!

#5

@bresch Thanks for letting me know about this.
I re-calibrated several times but not resolved this issue and only manually trimming the radio worked.
I thought deadzones are exist to mitigate or filter sensitivity of radio input however was not big enough.


https://logs.px4.io/plot_app?log=89457792-64d2-4e9b-9c9e-872b69a45757

#6

Good to see that you fixed it. I never checked the RC calibration so I don’t know exactly why it fails in your case. You can try to manually set the RC trim for the yaw stick (one of the RCx_TRIM parameters).