Quadcopter spin yaw direction

I have a question because the quadcopter is moving strangely. I’m using CubeOrang and here3 GPS. When flying after completing all the calibrations, the quadcopter was rotated in the yaw direction in stabilized mode. The control signal did not input anything other than the throttle. I will attach the flight log.
Does anyone know a solution to this problem?


PID side

Your PID values are as default, so I think they are fine:

MC_YAWRATE_I, 0.10000000149011612
MC_YAWRATE_P, 0.20000000298023224
MC_YAW_P, 2.799999952316284
MC_YAW_WEIGHT, 0.4000000059604645

However, you definitely don’t have the yaw control authority (you want the strength to reach around 1 and stabilize in the graph):

This leads me to believe that it is likely a hardware problem (more explanation below)


Your vehicle seems to be not yawing at all (32.566 mark above), even with almost maximum (0.88, which is 88% of the yaw torque you can exert) yaw torque setpoint (actuator_controls[0].control[2]).

This leads me to believe that perhaps your multirotor has one of the propellers spinning in a wrong direction, and thus can’t control the yaw properly.


Can you check whether the motors rotating direction & propeller mounting is all as expected?

Thank you for your reply!
I already check propeller direction and rotation it’s all work properly


I had a similar problem recently with a large hex copter running a Cube on ArduPilot. It flew just fine, but would slowly spin. The problem went away after I ran a full recalibration (accelerometer, radio, compass, and ESCs). I doubt all of that fixed it… but it may have been one or two of the above items.

Have you had any updates?