WARN [timesync] time jump detected. Resetting time synchroniser

I follow the ROS2 User Guide step by step:https://docs.px4.io/main/en/ros2/
But when I Start a PX4 Gazebo simulation,the issue will come:
WARN [timesync] time jump detected. Resetting time synchroniser.
WARN [uxrce_dds_client] time sync no longer converged
INFO [uxrce_dds_client] time sync converged

If i don’t open the client, there is no problem with the PX4 Gazebo terminate
How can I solve this problem

I remember the official said that synchronization could be cancelled in the simulation.

yes,I was not familar with QGroundControl,so I didn’t know how to solve it.
This problem is finished by
open QGroundControl->cilck left top side->find parameter in the left menu->search UXRCE_DDS_SYNCT-> set two parameters to value disable

thank you vary much :heart:

1 Like