Vtol cruise speed

I configurate Y6 Firefly 6 vtol drone in hase 60% throttle in cruise speed
Is this throttle for each motor or divide it for 4 motor (15% for each motor)

It’s relative to the throttle range of your radio, i.e. 60% between 0% and 100%. It will also be the approximate position of the throttle stick on your Tx.

Good luck.

Hi, it seems the FW_THR_CRUISE (cruise throttle) parameter. The throttle is divided by 4 motors. In other words, the throttle is the total sum of all 4 motors.

if each motor has 60% throttle i use 4 motor how much speed of drone? if throttle 60% each motor should has 18m/s speed and drone has above 75m/s speed… is this true?

It is sure that more thrust of motors will get more speed. But the relation between them may be not directly proportional. The shape of vehicle, the friction of air and physical equations are related to it. The exact relation is hard to make because complex equations are needed, I think.

The FW_THR_CRUISE (70%) parameter is divided for 4 motor or each motor?

In this case each motor outputs 70% throttle of its capability I think.

I use eCalc site for parameter if each motor has 70% throttle drone must has 4*42 km/h speed is this actually ??

Could you please post the upper half of that calculation? I want to see the parameters you used to arrive to this.


see this document

Since you’re not building a stock Firefly6 for 6S packs, I suggest you initially set it up like the High Efficiency params then install an airspeed sensor and follow the recommendation on testing. You can always opt to keep the airspeed sensor, as most quadplanes, so that the throttle is automatically controlled by the flight controller to ensure it doesn’t stall or it maintains configured cruise speed in all flight regimes.

Good luck.

airspeed sensor not work in QGC i test it

Make sure the following are enabled:

FW_ARSP_MODE - Airspeed mode
0: Normal (use airspeed if available)
1: Airspeed disabled

CBRK_AIRSPD_CHK - Circuit breaker for airspeed sensor
Comment: Setting this parameter to 162128 will disable the check for an airspeed sensor.

Reboot after changing values then calibrate in QGC.

Good luck.

yes default values are in normal mode but when calibrate start this message sent
airspeed not start calibrate
of course my flight is pixhawk v2

You’re using a digital sensor plugged into I2C port, right? (The analog plugged into ADC is unreliable). If you are, try swapping the two middle wires on the JST. If that still doesn’t work, either your sensor is defective or your Pixhawk doesn’t support that particular one and may have to use the SDP3X.

Good luck.

without airspeed sensor throttle is not control automatically?

i find parameter for motor number in my case is 4 please see

If you chose Firefly6 as your airframe, you shouldn’t have to mess with anything else. Just finish your build and test fly and tune for good hover flight.

Good luck.

I have one problem else i have below error
“mag sensor is inconsistance”
Is this critical?

If you have a GPS with a built-in compass, you can disable the internal one CAL_MAG1_EN and calibrate the compass again. Hope that resolves your issue.

Good luck.